FTP Server on your Mac (PureFTPd)

Discussion in 'Mac Basics and Help' started by kellymichelle, Apr 15, 2008.

  1. kellymichelle macrumors newbie

    Dec 23, 2006
    OK, like many who post, i'm at the end of my rope.

    I KNOW this is possible, to use your mac as your own FTP server.
    I have tried everything. Everything i can think of and everything that has been suggested to me. I am very enthusiastic about using PureFTPd Manager, and would love it if someone who has managed to successfully make this work for them would tell me how they did it.

    I have been able to get everything set up with a dynamicDNS service, and have created a host. I've gotten connected to my ftp server with the vitrual user accounts in PureFTPd (through that host even), but only on the computer i set it up on, and with a laptop that is connected to the same wireless network. No one outside of my network can access it.

    One person suggested that my ISP was blocking ftp access, but i called them and that is not the case. They suggested that my router was blocking the access, but I switched to my modem and it still wouldn't work outside of my network.

    Now I can't get it to work at all, not even on my own system. SO...I am really hoping someone will have a clear idea of how to set this up. I wouldn't be so frustrated if I didn't know it COULD work and is supposed to. I know I'm missing something.

    Please help me!
  2. stomer macrumors 6502a

    Apr 2, 2007
    Leeds, UK
    Are you using an Apple Extreme Base Station? If you are, you're virtually screwed. It doesn't port forward port 21 (nor 53 for that matter).
    If you aren't using an Apple Base Station, then check your router(your modem may also be a router) to make sure that your are forwarding port 21 to the correct machine.

    Make sure that your Mac isn't blocking port 21.

    By the sounds of it, you're not using the Macs built-in ftp server, so you need to make sure that it's turned off.

    Check Console.app for any errors message linked to your ftp daemon.

Share This Page