FTP suddenly stopped working

Discussion in 'OS X Yosemite (10.10)' started by zipadeedoodah, Mar 19, 2015.

  1. zipadeedoodah macrumors newbie

    Joined:
    Mar 19, 2015
    #1
    Today, all my FTP connections have suddenly stopped working. I thought it was a problem with FileZilla, but have since tried 4 or 5 different FTP clients and none of them will connect to anything. Sometimes the connection just times out, and other times it goes through all the authentication and login seemingly successfully before the message appears: 'Critical error: Could not connect to server'

    I'm using a 2011 MacBook Pro, upgraded to Yosemite about a month ago (and have been using FileZilla on a daily basis since), but otherwise I can think of no hardware or software updates that have been made.

    I've tried restarting my router and my computer. I've also checked the Mac firewall, which was already switched off. After googling the issue, I read that turning off 'passive mode' might fix it, but it doesn't.

    I haven't a clue how to go about fixing this problem!

    Any ideas?
     
  2. HenryAZ macrumors 6502

    HenryAZ

    Joined:
    Jan 9, 2010
    Location:
    South Congress AZ
    #2
    Have you tried from a Terminal prompt. Doing it "manually" may show you the point at which it is failing.

    For example:
    Code:
    $ ftp ftp.adobe.com
    
    Connected to ftpgen.wip4.adobe.com.
    220-ftp.adobe.com
    220-Adobe Systems, Inc.
    <snip>
    220-FTP client users:  To connect, use "anonymous" as the login,
    220-and use your e-mail address as the password.  For example,
    220-login: anonymous
    220-password: [email]ftpuser@adobe.com[/email]
    220-
    Name (ftp.adobe.com:henry): anonymous
    331 Please specify the password.
    Password: <enter an email address here>
    230 Login successful.
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp>
    
     
  3. zipadeedoodah thread starter macrumors newbie

    Joined:
    Mar 19, 2015
    #3
    Thanks for your response :)

    Connecting via Terminal works fine. It's just the FTP clients I'm having issues with.
     
  4. HenryAZ macrumors 6502

    HenryAZ

    Joined:
    Jan 9, 2010
    Location:
    South Congress AZ
    #4
    I suppose the next thing I would try would be to pick one of those clients, and create a new login profile from scratch. Use the simple one you tried from the Terminal prompt.

    Is there any useful information in system.log when this happens? Use the Console.app utility program to view the log. Keep Console open when you try a connection, and see what gets logged.
     

Share This Page