Full Keyboard Access is disabled on shutdown window after reboot.

UncleEk

macrumors newbie
Original poster
Nov 15, 2011
3
0
I'm yet another keyboard maniac and the first thing I did after upgraded to Lion was to turn on full keyboard access in system pref. All seemed to be good. I could access all the dialogs and windows. After a reboot, all the dialogs from any other apps can still be accessed via keyboard except one single window, the shutdown window (both from hitting apple->shutdown and control+eject.) I have to toggle control+f1 or control+f7 every freaking time in order to keyboard access the shutdown window. I've tried "defaults read -g AppleKeyboardUIMode" in terminal and it returned 3 which is "Full Keyboard Access ON and All controls" even after a fresh reboot. Also tried Fix Permission but the problem's not gone. Please, anyone could suggest the fix? Thanks in advance.
 

Watcherx

macrumors newbie
Feb 5, 2012
1
0
Greece
Same problem here!! I reset PRAM and install the new combo 10.7.3 nothing happened. The problem persists and I don't know why.
When I'm booting from my external disk I have the full access keyboard "capability" in my shut down dialog box but in my internal disk it's somehow deactivated.
 

fadhullah

macrumors newbie
Mar 20, 2012
1
0
I'm yet another keyboard maniac and the first thing I did after upgraded to Lion was to turn on full keyboard access in system pref. All seemed to be good. I could access all the dialogs and windows. After a reboot, all the dialogs from any other apps can still be accessed via keyboard except one single window, the shutdown window (both from hitting apple->shutdown and control+eject.) I have to toggle control+f1 or control+f7 every freaking time in order to keyboard access the shutdown window. I've tried "defaults read -g AppleKeyboardUIMode" in terminal and it returned 3 which is "Full Keyboard Access ON and All controls" even after a fresh reboot. Also tried Fix Permission but the problem's not gone. Please, anyone could suggest the fix? Thanks in advance.
UncleEK,

Please follow below steps to solve your issue, previously I'm also facing the same isssue:-

Run those command in Terminal

===============
+++++++++
Ben-MacOSX:~ Ben$ defaults read -g AppleKeyboardUIMode
3
+++++++++

But when I'm using sudoer to check the result was set to "0" means disable:-

+++++++++
Ben-MacOSX:~ Ben$ sudo defaults read -g AppleKeyboardUIMode
Password:
0
+++++++++

So what I do for the workaround/fix is by the set value to enabled it using root access level or sudoer:-

+++++++++
Ben-MacOSX:~ Ben$ sudo defaults write NSGlobalDomain AppleKeyboardUIMode -int 3
+++++++++

Once done do reboot your Mac & check the result in Terminal should shows as below:-

+++++++++
Ben-MacOSX:~ Ben$ sudo defaults read -g AppleKeyboardUIMode
3
=========
Ben-MacOSX:~ Ben$ defaults read -g AppleKeyboardUIMode
3
+++++++++
===============

Above steps solve my issue. Good Luck!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.