Full WiFi coverage but no internet

Discussion in 'iPhone' started by Portland Bill, Aug 13, 2012.

  1. Portland Bill macrumors newbie

    Joined:
    Aug 13, 2012
    #1
    Hi all,

    I have an iPhone 4S and I'm suddenly having problems with the WiFi connection on it.

    Although my WiFi at home is connected and my laptops and wife's phone work absolutely fine, I suddenly found Facebook and eBay apps were starting to timeout, and then Chrome started to do the same and now I find I keep having to restart my phone to get it to work on the WiFi which will last for 20mins or so and then just stop working even though the WiFi connection is still strong on the phone and my laptops continue to work fine.

    I've tried resetting my router and deleting all the associated devices and re-pairing the ones I still use, but it's still doing the same thing.

    It hasn't been dropped, I've never got it wet, and I'm pretty sure I haven't had any updates recently. I can't understand why it's suddenly playing up.

    Any ideas?
     
  2. Cougarcat macrumors 604

    Joined:
    Sep 19, 2003
    #2
    Does it happen with other wireless access points? That would tell you if the problem lies with your router or not (Though since your other devices are fine, I'm guessing it's the phone.)

    Try backing up your iPhone, and then wiping it. Before you put your stuff back onto it, try the wifi again. Do you jailbreak?

    Also, since you have a 4S, you are still under warranty. If a restore fails, I'd just go to the Apple Store and get it swapped for a new one.
     
  3. vyas22 macrumors newbie

    Joined:
    Jul 19, 2011
    #3
    This happened to me, I solved it by forgetting my wifi network in the settings and then joining it again, it has worked ever since.
     

Share This Page