Fullscreen games show only 1/4 of screen...

Discussion in 'MacBook Pro' started by Ploki, Feb 10, 2013.

  1. Ploki, Feb 10, 2013
    Last edited: Feb 10, 2013

    Ploki macrumors 68000

    Joined:
    Jan 21, 2008
    #1
    Why, when I try to run games, only the quarter of screen is shown?

    I.e. ioquake3 set at 2880*1800 will startup in quarter screen with four pixels on screen taking up 1 logical pixel... If i do change within the app, it shows up correctly.
    Galaxy on Fire 2 HD at fullscreen 2880*1800 shows up the same - 1/4 of screen in shown magnified by 2

    IS there any way to tell the damn graphic card to scale properly?
     
  2. leman macrumors 604

    Joined:
    Oct 14, 2008
    #2
    Well, by default OS X in HiDPI mode will upscale OpenGL views (the same way it does with images). This is done to improve performance in most applications. So I imagine that if the application requests a 2880*1800 window, the OS X gives it a 2880*1800 'logical' window if it is not coded in a proper way. I haven't actually played with that yet, so I can't tell anything more specific, but I suspect that there are some unpolished edges in the API that sometimes can lead to weird results. Or - the game is coded badly (for instance, it might query the OS for the actual hardware pixel resolution but not take pixel backing store into account).

    See also http://developer.apple.com/library/...html#//apple_ref/doc/uid/TP40012302-CH10-SW33
     
  3. Ploki thread starter macrumors 68000

    Joined:
    Jan 21, 2008
    #3
    Yeah, that's why I tried to run it native at 2880*1800, but the same phenomena occurs. I don't quite get it...
    Even if I run OS X at native res and snap a screenshot of fullscreen app, it just doesn't work.

    Windowed mode at native res does work normal though.
     
  4. Ploki thread starter macrumors 68000

    Joined:
    Jan 21, 2008
    #4
    So stupid. You just need to turn off automatic GFX switching... silly.. :)
     

Share This Page