Fully functional Rev. A - MBA, 64-Bit Windows 7 RC

Discussion in 'MacBook Air' started by CiscoGuru&aMac, Aug 22, 2009.

  1. CiscoGuru&aMac macrumors member


    Sep 14, 2007
    Hey guys,

    Hope to make some MBA owners very happy with this post.

    We've all read about the issues with running BOOT CAMP 2.0, 2.0.1, and 2.1 with Windows 7 @64-Bit on MBPs, let alone on the MBA.

    Lots of no sound issues, no keyboard backlighting (When applicable), track pad problems, iSight problems, etc, etc...

    Here's my setup:

    1. Rev A. MBA @1.6GHz
    2. Windows 7 RC @64-Bit
    3. BOOT CAMP 2.0.1 and BOOT CAMP 3.0 (Just for those wondering, running 10.5.8 on the OS X side and Boot Camp 2.0)

    Before I continue, I just want to say that my MBA is running flawlessly (For a week so far ;-). No manual installation of drivers, no missing drivers, and all 64-Bit.

    So here's the deal, after installing the 64-Bit version of W7, I attempted to install BOOT CAMP (BC) for Windows off of my #1 MBA OS X Leopard installation disk. My Rev A. MBA OS X Leopard disk shipped with BC version 2.0.1 on the disk, the MBAs had specific chipset drivers for BOOT CAMP, as denoted by the .0.1. As soon as I tried to execute the binary, I received the now very common error message, "x64 is not supported by this model", or something thereof.

    So, for a quick fix, I have a standard COTS Apple OS X Leopard disk, I threw that in my MBA Superdrive and installed BOOT CAMP 32-Bit for Vista/XP. Afterwards, I noticed the typical no iSight, no Keyboard Backlighting, No Sound, Dim display, non-functional trackpad, on and on.

    So I removed my standard OS X Leopard disk and placed my #1 MBA OS X Leopard install disk in the drive. I used windows explorer and located the 32-Bit binary, right clicked the file using the ALT-Key + Double clicking the trackpad bar (Remember the keyboard drivers weren't working either), I ran the 2.0.1 BC Setup.exe as a "Previous version of Windows" and voila! I was able to install 2.0.1 (With the keyagent/MAC HAL services failing, also now very common).

    Had I tried this ahead of time, I could have bypassed installing BC 2.0 and probably could have installed BC 2.0.1 @64-Bit, but I digress.

    The next step I tried was to install the BC 2.1 for x64 Vista update. I got the usual execute the binary and nothing happens routine, also very common. Some claim it works after a few minutes, I waited for about 5 minutes and nothing. The 2.0.1 drivers did nothing for me, obviously 32-Bit and incorrect drivers, same issues as I had with 2.0.

    So I did a Google and creatively obtained the 3.0 Snow Leopard BC for Windows .ISO for 32-Bit/64-Bit (Including W7).

    The .ISO is large, about a 1GB, so I downloaded the ISO, burned it to a DVD, ran the setup.exe, same error, "x64 is not supported by this model", or something thereof". So I didn't have much to lose, I used windows explorer again on the DVD, navigated to the BC directory, found the 64-Bit .EXE, did the ALT+double-click trick on the file, ran it as a previous version of windows, and BAM. BC 3.0 for 64-Bit W7/Vista ran like a charm, it immediately cleaned up all the missing drivers, installed the latest drivers (Took longer than other versions of BC I have installed), no non-starting service errors, just finished, prompted for a reboot, rebooted, everything sprang to life:

    1. Sound
    2. Backlit Keyboard
    3. Keyboard now works
    4. Trackpad now works
    5. Display brightness fully works

    So far all drivers working great. It's obvious that the W7 support in Snow Leopard's BOOT CAMP is going to make a lot of people happy.

    Just thought I would share this story as this was very simple. I think it's safe to say that several of my steps above can be bypassed.

    Download the Snow Leopard BC driver .ISO for your W7 @64-Bit, burn to a DVD, run after you install your W7 RC @64-Bit.

    Hope this helps all the MBP/MBA people struggling with this.

    I can now say W7 @64-Bit is NICE... :D

Share This Page