Function Key AND Audio Problems - Geek Squad Could Not Fix

Discussion in 'Windows, Linux & Others on the Mac' started by JTF-Chris, Jul 20, 2011.

  1. JTF-Chris, Jul 20, 2011
    Last edited: Aug 22, 2011

    JTF-Chris macrumors newbie

    Joined:
    Jul 20, 2011
    #1
    Hi, I'm really sorry if this has already been answered in previous threads. I tried doing a search on my problem and saw solutions that didn't seem to apply (or maybe I didn't understand them).

    I am posting for my boss, who bought a Macbook Pro even though she is not computer savvy and we told her to get a PC. So now that we have the Macbook Pro, I am left to try and solve her tech problems when I have never owned a Mac and have very very rarely operated one. So forgive me for my lack of familiarity, and for not knowing details like the make and date of purchase of the laptop in question. Even my boss can not help me there.

    Anyway, onto the problem. She had someone install Windows 7 onto the Macbook Pro because she doesn't like OS X and I think the issues are with that. First of all, the sound does not work. Right when the computer boots up, it plays that Apple sound (no red light in the jack), but then anything after that has no sound. I saw a red light in the headphone jack (it comes on AFTER start up), and tried to follow suggestions where you stick a pin into it and fiddle with the buttons inside, but no luck. When I plug in headphones, I get no sound either. I asked my boss if she has ever used headphones, and she said she has not. I did try to download the driver update that was said to fix Windows-on-Mac audio problem, but nothing changed.

    Next, the function keys only do what I guess Windows is set up for. I can't control brightness, volume, etc. I don't know how to...what is the term...re-map? I don't know how to re-map the keys when it is on the Windows OS. As a side problem, I also have no way to right-click in the Windows OS.

    And lastly, if I would need to get into the OS X to fix any of these problems, I do not know how to switch over to it. It automatically boots up on Windows. Oh, and I do not think Boot Camp was used.

    Sorry for the novel, but I wanted to get everything I already know/tried out there. Thanks in advance for your patience!
     
  2. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #2
    You need to install the Boot Camp drivers to fix these issues. Insert the Mac OS X install disc that came with the computer in the SuperDrive while booted to Windows and it should prompt you.

    B
     
  3. JTF-Chris, Aug 22, 2011
    Last edited: Aug 22, 2011

    JTF-Chris thread starter macrumors newbie

    Joined:
    Jul 20, 2011
    #3
    Hi, sorry to respond a month later, but I tried taking the Mac to Best Buy to have the Geek Squad try to remedy the problem since they knew what the issue was over the phone and made it sound like it would be a quick fix. I tried to find the OS X disc that came with the Macbook Pro but for some reason it wasn't in the box, or anywhere to be found. The Geek Squad took one of their own OS X discs and tried to run it but about an hour of trying to figure it out, they couldn't get anything to work. So now I'm back at the office without any OS X disc and trying to figure out what to do.

    I tried to download a few different driver update .exe files that were on Apple's website but when I tried to run any of them on the Windows 7 side, I got this error:

    "The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch."

    Of course, when I tried to run this on the Apple side, I was prompted with a message telling me I couldn't run an .exe file on Mac. I tried downloading WINE to be able to open the .exe (even though I'm guessing I was supposed to only open it on Windows side since, I mean, why would they make it an .exe if I was supposed to open it on Apple?). When I clicked "Go" nothing happened. Well, the X-11 icon comes up but when I click on it, nothing happens. Tried CrossOver too and again, nothing happened when I tried to install the .exe.

    This was for BootCamp_3.1.3_64-bit.exe from apple.com, which was supposed to remedy the headphone jack problem for Macs with Windows 7. I also tried BootCamp_Update_2.2.exe (which also said was supposed to fix the jack problem) and when I hit "Run", nothing happened, not even the message I quoted above. I tried multiple times, but nothing. I tried rebooting, but still nothing. It is 64 bit, not 32, I checked to be sure.

    The version of Boot Camp I found on the Apple side is Boot Camp Assistant 3.0.2. Can you figure out where I am going wrong? Do I have a wrong update? Am I not doing something right? I am so ready to punch my face in.
     
  4. SideStepSociety macrumors 6502

    SideStepSociety

    Joined:
    Feb 12, 2011
    Location:
    Vancouver, BC
    #4
    The Geek Squad are hacks.

    You need to either find/replace the DVD that came with the Mac, or boot to OS X, run Boot Camp Assistant, download and install the Windows drivers and burn them to a CD or copy them to an external drive.

    The files you downloaded were updates only, if I recall correctly, and won't install unless you have first installed said drivers from above.
     

Share This Page