Function keys not working AND sound sys pref greyed out

Discussion in 'Mac Basics and Help' started by playalinda, Apr 14, 2009.

  1. playalinda macrumors newbie

    Apr 14, 2009

    I just bought a 2.4 MBP model a1260. When I got home i noticed the volume keys were not working, and then i noticed none of the function keys were working properly. (example, f12 shows an eject CD symbol). So, the keys are working but not doing the standard functions such as volume and brightness.

    I have check and unchecked (and restarted) the "use all f1, f2 as standard function keys" to no result.

    Some other wierd things that seem to be related are:

    1. In the SOUND window in SYS PREFS all sound effects are greyed out. Under OUTPUT and INPUT it says no devices found.
    2. When i go to the itunes store in itunes and i double click on a song, it wont play. Not only is there no volume, but song wont play. Its the same with my own music from my cds.
    3. When i insert a DVD no volume control shows up.

    And the last superwierd thing (haha) is that I reloaded leopard and when the computer restarted up after install there was no OSX music that normally plays as the video flys thru the starfield.

    Headphones have no audio either.

    Sorry so long. The computer has no warranty of course.

    Any suggestions ??
  2. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Sounds like (ooh, unintentional irony) either your OS install got corrupted to the point that it's not seeing the sound hardware, or the sound hardware is actually broken.

    When it's off and you first push the power button do you get a startup chime? If not, that's a rather bad sign. If so, it's probably software, but also probably going to require an OS reinstall.

    Note that there are "simple" things that can cause sound output to fail, particularly the computer mistakenly thinking there's an optical audio plug in the headphone jack (can be solved by either repeatedly inserting/removing headphones or with a paperclip), but you would still see your sound output hardware listed in the pref pane were that the case.

    a1260 isn't a US model number, but I assume it's a used 2007 MBP and that's why it's not under warranty (no Applecare?). If so, bummer. You could try a full SMC and PMU reset--search Apple's site for the procedure. Can't hurt, anyway.
  3. playalinda thread starter macrumors newbie

    Apr 14, 2009

    thanks for the help.

    its definately an a1260, thats not a US machine ?? does that mean anything ?

    i AM getting a startup chime. does that eliminate the sound hardware being broken and make it a software problem ?

    thanks so much.

    (i am trying a software update, if that doesnt fix it i will reinstall. after that i will try the SMC and PMU reset. )
  4. playalinda thread starter macrumors newbie

    Apr 14, 2009
    problem solved

    Well thanks for all the help. I did the PMU reset and then updated the software and (poof) all is well again in macbookpro land.

    Thanks again!
  5. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Glad to hear it was something that simple. Something low level must've glitched out and stopped powering the sound hardware, I suppose.

    I stand corrected after checking more closely; I'm used to seeing Apple model numbers as listed on store pages, which are usually in the form of MA###LL. A12## seems to be normal to read off the bottom of the machine (maybe a CTO designation?). Just never paid that close attention after I finished ordering, I guess.
  6. hokasu macrumors newbie

    Sep 28, 2008
    Similar problem

    My sound output was greyed out too. I discovered that for some reason the sound output device had changed between boots (to CD spindoctor). Changing it back did the trick.

Share This Page