Fundamental problem with MAMP. Help needed.

Discussion in 'Web Design and Development' started by andy-h, Jun 25, 2009.

  1. andy-h macrumors newbie

    Joined:
    Jun 25, 2009
    #1
    I turn to you cause I have a major problem that I can overcome myself and the MAMP site seems to be down http://www.mamp.info/.

    When I start the MAMP and it opens the start page it just tels me that:

    Forbidden
    You don't have permission to access /MAMP/ on this server.
    Apache/2.0.59 (Unix) PHP/5.2.3 DAV/2 Server at localhost Port 8888


    I run WordPress 2.8 on it with ~three years old MacBook Pro with Tiger (10.4.11)

    I can open the start page of my WP projects. But when I'm trying to navigate further in the site is gives me: Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request.

    Here's some error logs. If someone more knowledgeable could understund these better.

    From apache_errol_log:
    [Thu Jun 25 15:26:15 2009] [error] [client ::1] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use 'RewriteOptions MaxRedirects' to increase the limit if neccessary., referer: http://localhost:8888/traveller/

    From mysql_error_log:
    090625 15:23:13 mysqld started
    090625 15:23:15 [Warning] You have forced lower_case_table_names to 0 through a command-line option, even though your file system '/Applications/MAMP/db/mysql/' is case insensitive. This means that you can corrupt a MyISAM table by accessing it with different cases. You should consider changing lower_case_table_names to 1 or 2
    090625 15:23:15 [Warning] One can only use the --user switch if running as root

    Everything has worked really fine for now almost two years I've uded MAMP. I restarted my computer, I reinstalled the MAMP.

    And where in MAMP folderstructure my databases life? I would really like back up them.

    Hope I provided enough info :)

    All help is tremendously appreciated! Thanks!
     
  2. andy-h thread starter macrumors newbie

    Joined:
    Jun 25, 2009
    #2
    Okay, I can now run my sites normally on MAMP after "resetting" the WP permalinks (turn them custom and back in %postname%). And the databases live, supringly enough ;), in MAMP/db.

    But what in earth is going on with the MAMP itself? I can't go to the PhpMyAdmin to export my databases. Is there some other way to export a databese?

    Thanks again :)
     
  3. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #3
  4. Wee Beastie macrumors regular

    Joined:
    Aug 20, 2007
    Location:
    In the snow with Rosebud
    #4
    Similar issue

    Hey angelwatt or andy-h,

    I have nearly the same issue. Same 403 Forbidden warning and everything. I am using MAMP to develop a WordPress site locally. Everything was working fine until a couple of hours ago. In the WordPress dashboard>Settings>General I changed the WordPress address and the Blog address. I clicked 'Update Changes' and that was that--everthing stopped working. I am unable to access phpMyAdmin at all (using MAMP). I get the 403 error message. The data is still there. I can see it if I type in the uri in my browser window. Ideally I would love to get access to the database in a format that I can use. I would also love to get MAMP working properly again as it is pretty indispensable for me right now. Any thoughts would be appreciated. If you need any more info, just let me know. Thanks!
     
  5. Wee Beastie macrumors regular

    Joined:
    Aug 20, 2007
    Location:
    In the snow with Rosebud
    #5
    Okay so I can access the database I need using terminal. I checked out the link that you provided about backing up the database, but I am missing something. I am following the instructions, but getting no results.

    This leads me to believe that I am not doing something right. A lot of tutorials like that one assume that the reader has experience using the terminal, which I do not. I feel like there is more to it that they are not mentioning.

    I can access the mySQL client and see the database that I need to get. Do you know what I should enter in the terminal to export it into a format that I might be able to import using phpMyAdmin on another server? That is my game plan at this point. After that, it is restore my system to a two-week old backup and just do what I can to catch up.

    This page helped me get access to my database along with the first link that you provided.
     
  6. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #6
    Can you show us what you tried? I'd likely be giving you the same commands that the article did. If there's any error messages though could help us tell you what's going wrong.
     
  7. Wee Beastie macrumors regular

    Joined:
    Aug 20, 2007
    Location:
    In the snow with Rosebud
    #7
    Angelwatt,

    Here is what I have done.

    -Launch MAMP
    -Launch Terminal
    -In Terminal: /Applications/MAMP/Library/bin/mysql -uroot -p
    -Entered password
    -The welcome message appears along with this prompt: mysql>
    -Entered: mysqldump -u username -ppassword database_name > dump.sql
    -Hit return
    -An indented arrow appears below like this: ->
    -I thought maybe it wanted a save location, so I entered a path and hit return and then an identical arrow appeared below

    Now as for the username and password I am supposed to enter, I am not entirely clear on. Is it gonna be the user login, which is "admin" or the mySQL username which is "root"? As for the password, I have the long WordPress hash, or the mySQL password which is "root". There could be a syntax error here as well. What do you think?

    Also MAMP is asking for my OS admin password upon launch. Do you think this could be a permissions thing? I already repaired permissions, so I don't know.

    Okay let me know if you need more info. Thanks for taking the time!
     
  8. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #8
    OK, I see the issue. The mysqldump command is used without logging into MySQL. Use these steps,

    1. Start MAMP
    2. Open Terminal
    3. mysqldump -u root -p database_name > dump.sql

    It'll ask for your password which is root. There will now be a file named dump.sql in your home directory.
     
  9. Wee Beastie macrumors regular

    Joined:
    Aug 20, 2007
    Location:
    In the snow with Rosebud
    #9
    Okay, thanks so much for your help. I just had to add a # symbol as the first character and it was good to go.

    Hopefully now I can import the database using phpMyAdmin on the remote server and recover the data. Then I can troubleshoot whatever is going on with MAMP. First I'll try reinstalling the program, which I already tried, but I'll give it another go, then I'll restore my comp to an earlier backup.

    Of course the backup is pretty old (few weeks)—I am kind of in a transitional phase as far as where I am living and I did not set my backup system where I am currently staying. I have a pretty good backup strategy, but stuff like this always seems to happen when I've let it lapse for awhile.

    Okay, done complaining. Thanks again for your time! This is more than once that you have helped me out. Hopefully someday I can return the favor!
     
  10. Wee Beastie macrumors regular

    Joined:
    Aug 20, 2007
    Location:
    In the snow with Rosebud
    #10
    Beating a dead MAMP

    Okay for anyone interested, I seem to have found a fix on the MAMP forums—which were down when this issue started for me. Problem is, I have no idea what the change I made really does, so I don't know if it will cause other problems. I opened Applications/MAMP/conf/apache/httpd.conf and edited the code below.

    Code:
    <Directory />
    Options Indexes FollowSymLinks
    AllowOverride All
    </Directory>
    I simply changed All to None

    Does this make sense to you guys? MAMP apache_error_log was throwing this at me:

    Code:
    [notice] Digest: generating secret for digest authentication ...
    [notice] Digest: done
    [notice] Apache/2.0.59 (Unix) PHP/5.2.6 DAV/2 configured -- resuming normal operations
    [error] [client ::1] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /Applications/MAMP/bin/mamp/
    [error] [client ::1] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /Applications/MAMP/bin/mamp/
    [notice] caught SIGTERM, shutting down
    I have not tested thoroughly, but the start page is usable again, which is encouraging.

    Found here: http://forum.mamp.info/viewtopic.php?f=2&t=6879&p=13992&hilit=forbidden#p13992
     
  11. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #11
    The change to none simply means that you can't set the Options differently using a .htaccess file in your directories. The errors you're seeing "might" mean that you currently have a .htaccess file that's trying to make some changes to the Options.
     
  12. Wee Beastie macrumors regular

    Joined:
    Aug 20, 2007
    Location:
    In the snow with Rosebud
    #12
    angelwatt,

    Okay, I found an .htaccess file at the root level of my hard drive. Here is its content (slightly edited to protect client's name):

    Code:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /ExampleSite/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /ExampleSite/index.php [L]
    </IfModule>
    
    # END WordPress
    What do you make of this?
     
  13. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #13
    That's just from WordPress. It's used to redirect the URLs to the proper name. It's used because you can setup WordPress to use different URL structures for posts. I found this page that talks about the error you're receiving and a line you can add to the top of the .htaccess file that may clear it up.

    Before the rewrite stuff add the line,
    Code:
    Options +FollowSymLinks
     
  14. Wee Beastie macrumors regular

    Joined:
    Aug 20, 2007
    Location:
    In the snow with Rosebud
    #14
    Hey sorry it has taken so long to get back. I haven't had a chance to test this out yet—still putting the finishing touches on the site remotely for now. I will explore this more once that project is wrapped up. Thanks so much for your help! Next time I'm in Dayton, I'm gonna buy you a sammich.
     

Share This Page