Funny DNS Issue!

Discussion in 'Mac OS X Server, Xserve, and Networking' started by xfarsightx, Jan 4, 2011.

  1. xfarsightx macrumors newbie

    Oct 29, 2010
    Hi All,

    I am using 10.5.8 Server on a PPC.

    I was trying to setup DNS service but failed on my first attempt and was trying to delete my current Zone entries. Every time I hit Remove and then press save the previous entry will automagically appears. I am a noob at terminal or using BIND so not sure how to go about doing it with CLI.

    My goal is to run DNS service within my office so that I can run SUS and create a transparent local apple software server update

    Any help or advice will be appreciated. Seriously this issue has been the biggest thorn this week. :mad:

  2. assembled macrumors regular

    Jan 12, 2009
  3. xfarsightx thread starter macrumors newbie

    Oct 29, 2010
    Thanks for the reply.

    I am able to add to the existing entry and see if I can make it right. Here are the settings:

    Primary Zone Name: netname.local

    Nameservers: servername.netname.local.

    Add Machine (record):

    Machine Name: servername.netname.local

    IP Addresses:

    A reverse zone is generated automatically.

    To verify I type in terminal: host

    and I get the message saying: Host not found: 3(NXDOMAIN)

    The host command with the IP address should resolve to the name of my server. I am clueless as to why this is not working. Again appreciate any help or advice.
  4. Alrescha macrumors 68020

    Jan 1, 2008
    Is the machine where you are typing that command actually using your server for DNS? What does /etc/resolv.conf say?

  5. xfarsightx thread starter macrumors newbie

    Oct 29, 2010
    @Alrescha: Yes

    I tried using the host command from both the server and the client. Client has as its DNS and I am able to surf the internet because the forwarding DNS settings in the Server Admin.

    However the host command is still not working, Not sure of which resolv.conf you asked for but here are both for client and sever:


    domain netname.local
    search netname.local


    nameserver x.x.x.x

    Here is the latest log from the Server Admin under DNS:

    05-Jan-2011 10:39:50.347 zone loading from master file failed: file not found
    05-Jan-2011 10:39:50.436 zone netname.local/IN/ NS 'servername.netname.local' has no address records (A or AAAA)
    05-Jan-2011 10:39:50.436 zone servername.local/IN/ loaded serial 2011010405

    Thanks again for the replies guys. :D
  6. richardhunt macrumors regular

    Oct 2, 2007
    I'm not famililar with OSX server and whatever frontend it uses to manage DNS entries, but bind is bind and it sounds to me based on the logs that:

    There's no "@ IN NS servername.netname.local"
    record in your domain file.

    There's not an actual IN-ADDR.ARPA db file in the bind directory. On most linux distributions theses files are stored in /etc/bind or /var/named look to see what is in those files.

    What is in your named.conf file?
  7. xfarsightx thread starter macrumors newbie

    Oct 29, 2010

    I glanced thorough the files but not sure what the settings should look like. Everything seems to be normal.

    I went thorough the files you mentioned and did not see any file named IN-ADDR.ARPA. The files were in /var/named in Mac OS X

    Here are the content for named.conf

    // Include keys file
    include "/etc/rndc.key";
    // Declares control channels to be used by the rndc utility.
    // It is recommended that be the only address used.
    // This also allows non-privileged users on the local host to manage
    // your name server.
    // Default controls
    controls  {
    	inet port 54 allow    {any;   }
    	keys    { "rndc-key";    };
    options  {
    	include "/etc/dns/";
    	 * If there is a firewall between you and nameservers you want
    	 * to talk to, you might need to uncomment the query-source
    	 * directive below.  Previous versions of BIND always asked
    	 * questions using port 53, but BIND 8.1 uses an unprivileged
    	 * port by default.
    	// query-source address * port 53;
    // a caching only nameserver config
    logging {
    	include "/etc/dns/";
    // Public view read by Server Admin
    include "/etc/dns/";
    // Server Admin declares all zones in a view. BIND therefore dictates
     // that all other zone declarations must be contained in views.
    I feel like the reverse DNS is not working properly.

    Here are some more error log:

    06-Jan-2011 11:01:49.062 host unreachable resolving '': 2001:dc3::35#53
    Above Log entry repeats quite often

    06-Jan-2011 11:35:44.408 freezing zone '' already frozen
    06-Jan-2011 11:35:44.408 freezing all zones: already frozen
    06-Jan-2011 11:35:44.500 loading configuration from '/private/etc/named.conf'
    06-Jan-2011 11:35:44.501 using default UDP/IPv4 port range: [49152, 65535]
    06-Jan-2011 11:35:44.502 using default UDP/IPv6 port range: [49152, 65535]
    06-Jan-2011 11:35:44.511 zone loading from master file failed: file not found
    06-Jan-2011 11:35:44.520 zone netname.local/IN/ NS 'servername.netname.local' has no address records (A or AAAA)
    06-Jan-2011 11:35:44.520 zone netname.local/IN/ loaded serial 2011010600
    06-Jan-2011 11:35:44.524 zone loading from master file failed: file not found
    06-Jan-2011 11:35:44.524 thawing zone '' file not found
    06-Jan-2011 11:35:44.524 thawing all zones: file not found
    06-Jan-2011 11:35:44.525 zone netname.local/IN/ NS 'servername.netname.local' has no address records (A or AAAA)
    06-Jan-2011 11:35:44.525 zone netname.local/IN/ loaded serial 201101060
    By the Way, You guys are amazing for responding quickly and guiding me. Thank you so much.
  8. Soverc macrumors member

    Oct 7, 2005
    Here is the issue, all tho I do not know how OSX server gui for DNS works, but in your bind files you need an "A" record set, If I remember correctly they are in /etc/dns

    servername IN A ;

Share This Page