Funny Memory Stick Problem

Discussion in 'Mac Accessories' started by jbrown, Jul 3, 2009.

  1. jbrown macrumors 6502a

    jbrown

    Joined:
    Jul 7, 2002
    Location:
    London
    #1
    Hello all,

    I just bought an 8 gig memory stick - that was advertised as being PC & Mac compatible. I put it in and it loaded fine. But when I tried to copy a file to it - it told me that the file name was too long. The name wasn't that long so I renamed it '1.jpg' - but got the same response. I tried other files and go the same.

    So I launched 'Disk Utility' and reformatted it using the 'Mac OS Extended ( journaled ) option. This worked fine.

    But this time when I tries to copy any files, it told me that the operation could not be completed because I did not have sufficient privileges to do this.

    Any ideas how I can get it to work?

    cheers all:)
     
  2. kornyboy macrumors 68000

    Joined:
    Sep 27, 2004
    Location:
    Knoxville, TN (USA)
    #2
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_0 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7A341 Safari/528.16)

    Go back into Disk Utility and Repair the Permissions for the drive. That should fix the problem. If it doesn't I'd return it.
     
  3. milk242 macrumors 6502a

    Joined:
    Jun 28, 2007
    #3
    Some memory sticks have a little switch on them to toggle back and forth fir write protection (can't copy anything to the drive) or no write protection. See if you have a switch like that
     
  4. jbrown thread starter macrumors 6502a

    jbrown

    Joined:
    Jul 7, 2002
    Location:
    London
    #4
    Thanks for the input guys!!

    Tried to repair permissions, but that option is greyed out, so I can't do that.

    Decided to do Repair, and it came up with the following:

    Verifying volume “Untitled”
    Checking Journaled HFS Plus volume.
    Invalid node structure
    Volume check failed.

    Error: Filesystem verify or repair failed.


    There is no switch on the drive.
     

Share This Page