Fusion + 10.5.2 = slow graphics

Discussion in 'Mac Apps and Mac App Store' started by retro83, Feb 12, 2008.

  1. retro83 macrumors member

    Joined:
    Feb 3, 2008
    #1
    Since the 10.5.2 and graphics updates last night, my VMWare Fusion install of XP has become slower.

    You can easily demonstrate this by dragging a window around on the desktop, it now suffers from savage glitching and tearing whereas it was perfectly smooth before.

    I've tried uninstalling and reinstalling the Vmware tools and rebooting a few times but it's still slow.

    Anybody know how to solve this one? (this is a X3100 Macbook btw.)

    Cheers!
    R. :confused:
     
  2. retro83 thread starter macrumors member

    Joined:
    Feb 3, 2008
    #2
    Apologies for bumping my own post, but I installed Parallels demo, and it also is much slower than when I'd previously tested it.

    Anybody else with a Macbook experiencing these problems?

    PS. I also tried fresh installs of 2000 on both VMs and they are both still really slow.
     
  3. KingYaba macrumors 68040

    KingYaba

    Joined:
    Aug 7, 2005
    Location:
    Up the irons
  4. kfordham281 macrumors 6502

    Joined:
    Dec 4, 2007
    #4
    Apple released an update to "Leopard Graphics" yesterday too. It requires 10.5.2 so it probably won't show up until you have that installed.
     
  5. retro83 thread starter macrumors member

    Joined:
    Feb 3, 2008
    #5
    Thanks for your replies!

    I've done quite a bit of testing now - reinstalling with and without various updates and the conclusion I've reached is that as soon as you install the Leopard Graphics Update 1.0 the graphics in VMWare become jerky.

    Apparently this only affects the X3100 Macbooks. I've posted over at the VMware forums where somebody was kind enough to submit a bug report for me, and I've posted a bug to Apple as well.

    Hopefully between them this will get squashed!
     
  6. noetus macrumors member

    Joined:
    Sep 3, 2007
    Location:
    New York Cirty
    #6
    It helps quite a bit to disable the themes service and run a Windows classic session. That's also a good idea anyway (both for aesthetic reasons and to minimise the resources Fusion sucks up when your Windows VM is running), in my opinion, but it definitely helps with this until it is fixed.
     
  7. Ledgem macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #7
    I'm using a Macbook Pro and haven't noticed this, but I haven't noticed it on my girlfriend's Macbook either (not sure what the graphic chipset on her system is though - it's a Mid-2007 Macbook). I disabled the graphics acceleration (for DirectX) on her WinXP virtual machine, though. I'm guessing you've tried that? (Hopefully it isn't essential for you to have that, and hopefully the VMWare Fusion team will get this resolved soon)
     

Share This Page