Fusion drive on MacBook Pro Mid2012

Discussion in 'MacBook Pro' started by Kayzey, Jan 7, 2013.

  1. Kayzey macrumors newbie

    Joined:
    Jan 7, 2013
    #1
    Hey all,

    Trying to get a fusion drive working on my MacBook Pro. But I am running into some trouble after installing Mountain Lion.

    I have a 64gb SSD and the 500g HD that came with the laptop.

    I manage to create the fusion drive, install and otherwise get to the desktop. The problem happens when I run the last update from the App store. After the reboot I am stuck with two drives and none of them will boot. The recovery parition is gone.

    Seems like the fusion drive breaks with the update and leaves me with two disk that aren't working. But if I boot from USB stick I still see the whole drive and everything appears to be as it should.

    Any help would be great!

    Alittle more info

    I am using disk0s2 and disk1s2. So I am not whiping the disks, I read that this was the best way on notebooks, so I can keep the recovery parition and so on.
     
  2. gdourado macrumors 6502

    gdourado

    Joined:
    Apr 22, 2010
    #2
    I am also having doubts about fusion drive...
    From what I read, the Macmini 2012 comes with diskutility 13 (444). My OSx 10.8.2 has version 13 (430).

    From what I read, a true Fusion Drive with smart data migration between SSD and HDD can only be created by version 444. If you use another version, you end up with a standard core storage volume...

    Is this true?
    Any way to install 444 on my system?

    Cheers!
     
  3. Kayzey thread starter macrumors newbie

    Joined:
    Jan 7, 2013
    #3
    Well, I am writing this from the MacBook Pro with Fusion enabled. But, I am pretty sure if I run the update again, my drive will fail.

    ----------

    Here is the layout from the diskutil cs list command
    Code:
    Logical Volume Group 59D28985-942B-43A2-9E32-56C1A04C94EA
        =========================================================
        Name:         MachintoshHD
        Size:         562411601920 B (562.4 GB)
        Free Space:   20124131328 B (20.1 GB)
        |
        +-< Physical Volume 75D612D4-68F9-4A5A-A7C0-9E870FEF12E2
        |   ----------------------------------------------------
        |   Index:    0
        |   Disk:     disk0s2
        |   Status:   Online
        |   Size:     63163498496 B (63.2 GB)
        |
        +-< Physical Volume 6520380E-CB3D-497E-9B4F-288E46829852
        |   ----------------------------------------------------
        |   Index:    1
        |   Disk:     disk1s2
        |   Status:   Online
        |   Size:     499248103424 B (499.2 GB)
        |
        +-> Logical Volume Family 7E0CA3D6-4B47-4D91-9759-49461CC8D0FB
            ----------------------------------------------------------
            Encryption Status:       Unlocked
            Encryption Type:         None
            Conversion Status:       NoConversion
            Conversion Direction:    -none-
            Has Encrypted Extents:   No
            Fully Secure:            No
            Passphrase Required:     No
            |
            +-> Logical Volume 8DF597A1-68DB-4130-BA98-490866769D89
                ---------------------------------------------------
                Disk:               disk2
                Status:             Online
                Size (Total):       539484340224 B (539.5 GB)
                Size (Converted):   -none-
                Revertible:         No
                LV Name:            MachintoshHD
                Volume Name:        MachintoshHD
                Content Hint:       Apple_HFS
    
    And diskutil list

    Code:
    /dev/disk0
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *64.0 GB    disk0
       1:                        EFI                         209.7 MB   disk0s1
       2:          Apple_CoreStorage                         63.2 GB    disk0s2
       3:                 Apple_Boot Boot OS X               134.2 MB   disk0s3
    /dev/disk1
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *500.1 GB   disk1
       1:                        EFI                         209.7 MB   disk1s1
       2:          Apple_CoreStorage                         499.2 GB   disk1s2
       3:                 Apple_Boot Boot OS X               650.0 MB   disk1s3
    /dev/disk2
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:                  Apple_HFS MachintoshHD           *539.5 GB   disk2
    


    ----------

    The update that breaks it is called MacBook Air and MacBook Pro update 2.0 - which should just fix graphics performance and USB issues.
     
  4. Kayzey thread starter macrumors newbie

    Joined:
    Jan 7, 2013
    #4
    After further research. It would seem that is a problem with my SSD, which is a OCZ Octane s2 media. Apparently OCZ is having problems with their firmware.
     
  5. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #5
    See all of 2010.
     

Share This Page