Fusion issues with Yosemite

Discussion in 'OS X Yosemite (10.10)' started by mirage2130, Oct 30, 2014.

  1. mirage2130, Oct 30, 2014
    Last edited: Oct 30, 2014

    mirage2130 macrumors newbie

    Joined:
    Jul 1, 2008
    #1
    Hello everyone. Since I can't locate any fusion guides specific to Yosemite, does anyone know if the process to create a fusion drive is different, or should a guide for Mavericks or even Mountain Lion work?

    I have a late 2012 Mac Mini running Yosemite. I decided to install an SSD and a new HDD in the machine and create a fusion drive; removing my original hard drive that the machine came with.

    Well, it has been nothing short of a nightmare. Both drives are installed in the Mini and if I boot off my original hard drive as an external drive, the machine sees both the new HDD and SSD, can format and read them no problem. I have followed various how-to's online and the fusion drive will create and mount no problem. My machine sees it as one drive with the correct amount of space. I cannot get Yosemite to install on this newly created fusion drive, however. I tried a few different ways as well. If I boot off of my Yosemite recover USB I get a Cocoa -1 error almost immediately after the install starts. It gives me the option to restart and if I do, I get the same error.

    If I boot off of my original recovery partition on my now external hard drive, it will download the install files just fine, but when it reboots, it reports that the files cannot be found.

    I have also tried using Carbon Copy Cloner to clone my original drive onto the fusion drive. It copies about 1gb worth of stuff and then gets an error saying that the drive is no longer mounted. At this point, if I check disk utility, the fusion drive is dismantled and it's only showing the SSD; the HDD will not show up unless I reboot the machine, boot into the USB recovery and issue the command to split the fusion drive.

    Some things to consider.

    I previously had a fusion drive setup on this machine, which was created with Mavericks. The fusion drive failed about 8 months later and at that time I split the fusion and just used a hard drive, removing the SSD. Recently however, I got the fusion itch again and decided to give it another go, this time under Yosemite. I bought a new HDD, two actually.

    The first HDD I bought had the problems listed above so I returned it, thinking the drive was defective. I purchased a second HDD and it's having the exact same issue, so I think it's probably safe to say it's not the HDD.

    As mentioned above, both the HDD and SSD can be seen independently in Yosemite and work fine as plain hard drives.

    I have a few other posts on this forum that sort of document my progress and everyone has been so helpful in answering my questions. I am very appreciative.

    If nothing works, I'm just considering having the SSD as my boot drive and having the HDD as my data drive.

    Thank you
     
  2. mirage2130 thread starter macrumors newbie

    Joined:
    Jul 1, 2008
    #2
    I ended up figuring this out and it was very simple. The SATA ribbon cable that attached my HDD had a very very small tear in it. I replaced this cable and all is well.
     

Share This Page