Fusion-Tools upgrade failed

Discussion in 'Windows, Linux & Others on the Mac' started by Tmlcky, Feb 25, 2009.

  1. Tmlcky macrumors newbie

    Joined:
    Feb 6, 2009
    #1
    Dear all,

    I have an iMac20 with WMware Fusion with XP installed as a virtual machine.
    I have recently upgraded Fusion to the Version 2.0.2 (146107).

    After that, I then tried to upgrade the Tools (Virtual Machine submenu)
    but the Tools installation failed and stopped because of the internal error 2229.

    I was told to first uninstall the Tools, according to the following Fusion Help instructions, that is:

    In Terminal, type:

    sudo /Library/Application Support/VM Tools/poor_man_uninstaller.sh
    (plus enter)

    Close Terminal.

    Actually, I was asked to enter my password. However Terminal could not find the above *.sh file (so it failed ?.

    Any hint, please?
    (in the meanwhile I lost the audio in XP)

    Tmlcky
     
  2. nospamboz macrumors regular

    Joined:
    Oct 3, 2006
    #2
    I'm not sure where you got that information from. There's no such pathname installed by Fusion, at least in 2.0.2. Maybe it's old information?

    Anyway, I often have to un-install VMWare Tools to get an upgrade to work properly. I just do it within Windows XP via
    "Control Panel">"Add and Remove Programs">"VMWare Tools", selecting "Remove". Try that.
     
  3. Tmlcky thread starter macrumors newbie

    Joined:
    Feb 6, 2009
    #3
    I got that odd file name from WMware help menu.
    Anyway I got the same hints somewhereelse and it worked finely.
    Thank you
     

Share This Page