FW 3.1.3 Tethering bug when charging!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by andygabriel, Feb 21, 2010.

  1. andygabriel macrumors regular

    Joined:
    Feb 1, 2009
    #1
    Hi Macrumors,

    I'm not sure if it's just me but i've found a bug in FW 3.1.3. I have an official unlock iphone 3G(NZ). After 3.1.3, i got native tethering working(non-jailbreak). But when i connect USB tether my iphone to my mac, it drains the battery of the iphone when it's suppose to charge.

    Then i tried with bluetooth and keep the iphone plugged in to charge while i'm tethering via bluetooth. It still drains the iphone battery.

    I don't understand how can the battery charge drains when the iphone is being charged.

    Has anyone experienced that as well.

    So it means no matter what your iphone battery will discharge when tethering. Sounds like a bug to me!
     
  2. RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #2
    Does it do this on other computers?

    Does it do this on other USB ports?

    Does it charge when you aren't tethering?
     
  3. andygabriel thread starter macrumors regular

    Joined:
    Feb 1, 2009
    #3
    Yes it charges when not tethering.

    It does the same on other USB ports and computers.

    It just doesnt charge when tethering via USB or bluetooth.

    Have u checked and see if yours does the same?

    Plz let me know. Mayb i should reinstall FW 3.1.3 again.
     
  4. Kyeris macrumors 6502

    Joined:
    Jul 19, 2008
    Location:
    Somewhere in Texas
    #4
    I don't believe this is a bug.

    Even when I first got an iPhone 3G on 2.0, if it got too hot it will refused to take a charge, same with my 3G S.

    Ex. on a long call with 3G while browsing the web or using other apps and using GPS in a car constantly for a long period of time (both while trying to get a charge in)
     
  5. SpaceKitty macrumors 68040

    SpaceKitty

    Joined:
    Nov 9, 2008
    Location:
    Fort Collins Colorado
    #5
    This is normal. It usually happens when the phone starts to get hot so I think what happens is the charging circuit shuts off to protect the phone.

    This happens to me when I use my XM app. After about an hour, the battery will start to drain. This happens on all three of my iPhones so there is nothing wrong.
     

Share This Page