FW drives not mounting but are powered

Discussion in 'MacBook Pro' started by Mike Boreham, May 4, 2014.

  1. Mike Boreham macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #1
    17 inch MBP 2011 with 10.9.2.

    Three different FW800 externals are not mounting on desktop (or being seen by DU), with different leads. Same drives mount fine on 2008 MBP and Mac Pro. The drives are receiving power because light comes on. Same drives mount fine by USB on the problem machine.

    Tried SMC and PRAM reset without success.

    This machine belongs to a relative some distance from me, so I haven't seen it directly since the fault started, but it is sounding like a trip to a Apple repair place.

    Has anyone similar experience? what was the solution?

    Thanks
     
  2. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #2
    Have the user test by starting up to the Recovery partition and opening Disk Utility. Do they mount there?
     
  3. Mike Boreham thread starter macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #3
    Thanks. The machine is actually set up (by me) with a homebrew Fusion Drive, without an internal RP. There is an RP on one of the externals so he could boot from that (by USB) and see if FW then works. I guess your thinking is that the main installation might be corrupted so that FW is not working, but would from RP or another install.

    I am going to visit next weekend so I think he will probably leave it till I come.
     
  4. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #4
    I'd guess that disk has a full OS on it then. Yes, that's what I was getting at: that something in the internal OS is corrupt and causing Firewire to fail. This does seem unlikely but since troubleshooting is free, might as well try.
     
  5. Mike Boreham, May 10, 2014
    Last edited: May 10, 2014

    Mike Boreham thread starter macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #5
    I have now been able to troubleshoot the machine personally, but without success.

    The most significant thing for me is that System Profiler reports "No Firewire ports detected", even without a FW device attached. (A healthy MBP gives info about the FW port in same situation)

    Things I have tried:

    SMC reset
    PRAM reset
    Reinstall 10.9.2 as full install
    Booted from another drive
    Different leads and different firewire drives
    Powered Firewire devices
    Left shut down for 30 mins
    Tested firewire devices and cables on another mac
    Repaired permissions
    Disk Utility repair
    Close visual inspection of port

    Probably some others I can't remember...

    All seems to point to a hardware failure, except that Apple Hardware Test (internet) says no fault found.

    There seems some ambiguity about whether AHT actually test the firewire port. Since System Profiler is not finding any ports I would have thought AHT was capable of recognising that there ought to be a port, and therefore recording a failure. However this link implies maybe not.

    Googling the System Profiler message finds many people who have recovered from it by reinstalling the OS, sometimes a long time afterwards, so I was hopeful this would work but seems not.

    Anyone got any insights or advice?

    Th
     

Share This Page