FW hard drive will not mount

Discussion in 'Macintosh Computers' started by antokin, Dec 23, 2004.

  1. antokin macrumors newbie

    Dec 23, 2004
    This is a really strange problem where the drive is visible in Disk Utility and all other disk apps, but refuses to mount. In Disk Utility, when you click on "mount" it act like something is happening for a second, but never mounts. This is a FW drive that is in an enclosure with Oxford chipset. The computer is Mirror Drive Door dual running 10.3.7

    This all started when our freelace editor was working on Final Cut. He said that out of nowhere there was a really harsh static sound in the headphones and the windows on the screen turned to multi-colored junk fragments. Ever since then everything is fine, but this drive will not mount. Tried it on a different computer with same results.

    The strage thing is that all disk programs see the drive fine, and when I run a repair, no problems are reported. I guess that makes sense, since during the repair process the disk apps dismount the disk they are examining. So it looks like all the data is still there, but I can not access it. When the drive is plugged into the computer nothing happens - no error message - the drive does not show up on the desktop, but it is visible through disk apps.

    If there is no solution to fix the drive, is there a way to get the data off the drive without mounting it? The disk apps seem to be able to do it...how can I have this access? There are many hours of digitized video on this drive that would take days to re-digitize, so I really would like to save the data.

    The drive is Maxtor DiamondMax 80 gig drive. It's been working fine up to now for several years. I've also tried Disk Warrior (hangs), TechTool (reports that everything is fine), and Drive 10 (also reports that there are no problems.

    Any ideas are greatly appreciated.

  2. jeremy.king macrumors 603


    Jul 23, 2002
    Fuquay Varina, NC
    You can try to pull the drive out of the enclosure and throw it in your MDD. If it still fails to mount, your drive has issues. If it mounts/works fine, you have a bad enclosure.

Share This Page