FW800 freezes com puter ?

Discussion in 'iMac' started by nuno1959, Mar 5, 2012.

  1. nuno1959 macrumors member

    Joined:
    Oct 19, 2009
    #1
    Hi guys !

    after much success with simple USB W.Digital My Books for a number of years to store my extensive iTunes library, photos, etc… having read so many wonderful things about OWC/NewerTech Guardian Maximus Quad interface Raid box, i decided to take the plunge, ordered one & installed 2 Western Digital Caviar Green 3TB bare drives in it

    using CarbonCopyCloner i copied the content to these & started using it.
    right from the start i noticed my late 2009 27'' iMac i7, with 16GB RAM, constantly ''freezing'' when connected via FW800 yet when i tried it via USB it was all good !?..

    i have 4 more W.Digital My Book drives, an H.P C6180 all in one printer, a Cambridge Audio DacMagic, an APC UPS connected to my computer via USB through a pair of Logitech Premium powered USB hubs + my HD plasma TV via mini-DisplayPort/HDMI adapter & a Wacom Cintiq 21UX also via an adapter

    thinking it might be caused by some weird incompatibility between any one of these components or so, i unplugged EVERYTHING from my iMac, made sure EVERY power supply for the above were ALL in working order ( they are.. ) checked & double checked ALL the cables ( even got a couple of new ones just in case..) checked the USB hubs + their power supplies, you name it - EVERYTHING IS O.K. !

    tried plugging in one component at a time - everything worked fine ! however each & every time i plugged in the Guardian Max via FW800 it happened, time & again....regardless if plugged by itself or in combination with any other component
    funnily enough the Guardian Max connected via USB gave no problems whatsoever !?
    after a little ''Googling'' i could see i'm NOT alone with this sort of problem among Mac users & that it happens with all sorts of drive makes ….as long as FW800 is being used !?

    has anyone come across this quirky behavior or has any idea what might be the solution for this ?

    i mean, to stream the music, USB is plenty fast but it's still frustrating to have intentionally bought a FW800 capable box & not be able to use its advantages

    many thanks !
     
  2. Smacky macrumors 6502

    Joined:
    Jul 23, 2008
    #2
    Yeah I have a drobo connected to a Mac via fw800, when the connection is put under load, e.g. copying a huge file or several huge files, the rest of the system will come to a crawl. Actually finder becomes non responsive and the progress indicator will sometimes freeze. Not sure what the solution is though
     
  3. harcosparky macrumors 68020

    Joined:
    Jan 14, 2008
    #3
    I am using a single drive enclosure ( G Drive ) via FW800 and have absolutely no issues with it.

    I initially used it as a 'boot drive' with a test install of OSX LION and now use it as a storage device for photo libraries attached to my iMac.

    Considering your problem and the problem *Smacky* mentioned with his DROBO, it sounds like it has something to do with multiple drive enclosures or more to the point with the RAID controllers in those enclosures.

    I wonder what RAID Controller is in the DROBO and which is in the OWC solution?
     
  4. nuno1959 thread starter macrumors member

    Joined:
    Oct 19, 2009
    #4
    Hi Harchosparky !

    & thanks for your input ! as far as i can tell their enclosure has a ''high speed Custom Oxford 946DSE/3100 Integrated Chipset featuring FireWire 800/400, USB 3.0/2.0, and eSATA ports ....'' as one can read in OWC's website..

    at this point, i'd like to believe it will be a question of some newer firmware or something along those lines to sort it.
    to rule out being something definitely wrong with the box/my iMac, tomorrow i'm taking it to a friend's place to hook it up to his iMac ( exact same as mine.. ) via FW800 & see what comes of it....

    i also contacted OWC & am waiting for them to get back to me see if i can make some sense of it all - i'll keep you guys posted !

    cheers

    Nuno
     
  5. Smacky macrumors 6502

    Joined:
    Jul 23, 2008
    #5
    The drobo 2nd gen has according to wikipedia:

    Marvell 500 MHz System-on-a-chip (SOC) processor (Marvell 88F5281-D0)
    (Same processor used in the Apple Time Capsule and in several other NAS devices)
    Marvell PCI-X 4-Port SATA-II Controller (Marvell 88SX6042-BCZ1)
    1 GB RAM (2x Hynix H5PS5162FFR 512Mb DDR2 SDRAM 2-5-5-5)
    128 Mb NOR flash memory (Spansion GL128P90FFIR2 90 nm, 25ns page access, 90ns random access)
    64 Macrocell PLD (Programmable Logic Device - XILINX XC2C64A
    3 Port Firewire 800 (1394b) controller (TI XIO2213AZAY - PCI Express)
     
  6. nuno1959 thread starter macrumors member

    Joined:
    Oct 19, 2009
    #6
    finally ?..

    Hi Guys

    me again & this time i think it's good news - knock on wood !….

    as someone had very rightfully suggested, i took the Guardian Maximus to a friend's place, connected it via FW800 to his iMac ( exact same model/year as mine.. ) did ALL I COULD to make it stumble like read & write several LARGE files of 20, 40, 60 AND 85GB SIMULTANEOUSLY &……NOTHING WENT WRONG !!?….then we went out for dinner, took our time ( question of giving time for the drives to go to sleep/park & perhaps create yet another situation which somehow could cause the freezing ?.. ) returned, all was good, drives woke up immediately to stream some music when prompted to...
    then kept going at it for 5 more hours & ALL went well..the G.MAX didn't miss a single beat/bit - how's that for a bad pun ?

    so when i returned home i created a new user account on my computer, logged in & again pushed the GMAX as much as i could : did this for roughly 6 hours & nothing went wrong ! after that i ejected the drive, logged back into my regular user account, ran Onyx to ''clean house'' a little, restarted it, switched on the drive & it's been now a day & a half NOTHING has gone wrong !?
    maybe it was just some gremlin who meanwhile got scared & ran for his life ? who knows ? i swear, sometimes my computer seems to have a life of his own….

    the only difference between then & now i can think off is that before i had the FW800 cable running right above this row of wallwarts/sockets & now it's on top of my desk - could it be this interfered negatively w/ the FW800 cable/signals ? electromagnetic fields/interference & all that ?…..

    please check photos here :

    http://www.flickr.com/photos/13706825@N03/6820385432/in/set-72157629545606505/lightbox/

    - the 1st pic shows the path of the FW800 cable as i had it before
    - the 2nd shows how it's laid out now
    - the 3rd's the same just behind the computer itself

    later i WILL try again running the cable under the desk but will get maybe some shielding of some kind ? it's just that i just HATE having them cables all over the place, you know ?..
    anyway for the time being i'm VERY happy with this outcome. now i guess only time will tell if any misbehaving returns or not

    so, for the time being i'm just going to lay back & enjoy my music while i work ! ;-) if anything happens down the line i'll let you know even if just for the sake of sharing details for future reference

    a big thank you to everybody who ''chipped in'' trying to help solving this, it feels good to know one can resort to this forum anytime something happens & that people WILL actually try to sort thing out !… ;-)
    have a good week-end guys

    cheers

    Nuno
     

Share This Page