G Drives not showing up on Imac

Discussion in 'iMac' started by pmalone100, Nov 7, 2012.

  1. pmalone100 macrumors newbie

    Joined:
    Oct 31, 2011
    #1
    1. I have an Imac that I use for editing in final cut 7 but render and do all the work to my G Drive 2 Ter external hard drives.

    2. Today out of nowhere my imac will not recognize any of my 4 hard drives I can plug and unplug and nothing happens..

    3. I have not changed anything since yesterday when all was working well.

    4. I have changed cables with new cables that I know work.

    5. I plugged each hard drive in to my mac book pro and they pop right up no problem.

    6. Finally, I have made sure everything is checked properly in finder/preferences, etc... as I said it was all working perfectly yesterday at time of close...

    Now it's like my imac just doesn't read them... thank you in advance for your help.
     
  2. peeaanuut macrumors 65816

    Joined:
    Sep 10, 2007
    Location:
    Southern California
    #2
    have you tried changing the ports they are plugged into? I know it sounds weird, but that happened to me on my mini and that was the solution.
     
  3. martinm0 macrumors 6502a

    Joined:
    Feb 27, 2010
    #3
    Also check Disk Utility and see if this show up there at all. Peripherals sometimes just get a little out of whack.
     
  4. michaelmac macrumors member

    Joined:
    Jun 27, 2006
    #4
    Same thing happened with me a while back - the fix was one of those things that you read about and think no it can't be that. It was the power pack/cable. Used another one and it worked fine! Worth a try.
     

Share This Page