G4 2x500 power but no chime, no video, no usb

Discussion in 'PowerPC Macs' started by LittleJoe, Mar 6, 2008.

  1. LittleJoe macrumors regular

    May 23, 2006
    Worthington, OH
    hi guys...

    Ive got a G4 Power Mac 2x500MHz that Im getting a bit frustrated with.

    - Power supply seems to work as power flows once I hit the power button. Fans spin, red light comes on the board, connected drives spin up, drawers open.
    - No chime. At first it was sporadic, but now non-existent.
    - No video output. Has the original AGP ATI 128 Rage Pro graphics card.
    - No power to USB ports? Try plugging in devices that light up in USB but nothing happens.

    What Ive tried:
    - Ive replaced the board with a known good board and get the same results, and of course i thought this was the main problem. I did get a tiny whiff of burning smell from the previous board, though no signs of physical defect on it. No smell from the new board.
    - Replaced and swapped around about 6 different ram sticks.
    - Tried PCI graphics card (probably not compatible though) and no results, as expected.
    - Reset PMU of course.
    - Swapped processors.

    Im kind of at a loss. The no video i figure can be a bad video card, but Im reluctant to buy a card since there is no boot chime and no power to the usb hubs. The only thing I can think of is that the power supply is partially failed? I dont even know how possible or likely that is. One odd thing. With the original board in the machine the optical drive gets power and opens. With the new board the optical drive wont budge. Thought that was weird. Also, with either board when a 3.5" drive is plugged in it powers up and spins, however if I actually connect it with the ATA cable it does not spin.

    This is the first mac desktop Ive gotten into. Ive gutted lots of apple portables, and figured the experience would translate well but apparently not. :confused:
  2. Firefly2002 macrumors 65816

    Jan 9, 2008
    Hm. A start could be zapping your PRAM... since you don't get a chime, your best bet would be to take it out and put it back in. Though, it might be dead, so you just might need a new one.

    Another good idea might be to try the Apple Discussion forums... people who have Sawtooth G4s will probably be able to better help you. Try the PRAM first though, it's worth a shot. You could also try reseating everything to make sure it's all firmly in place.


Share This Page