G4 Cube - DS2 Red Light - Crashing

Discussion in 'PowerPC Macs' started by serdar13, Jul 17, 2018.

  1. serdar13 macrumors newbie

    Joined:
    Jul 17, 2018
    #1
    Hi G4 Cube owners, I was wondering if any of you could help. I am trying to fix my G4 Cube which crashes on startup. I get the apple logo and then gets stuck on that screen. I noticed a red light near the ram which is DS2 and was wondering if this is the culprit.

    I have tried another ATI Rage 128 Pro from a G4 Tower with a faceplate swap but again no joy thinking it might be graphics card.

    I booted to open firmware and reset nvram but no joy. It was working up until a few months back so would be good to get it back up. I have 10.5.8 running on an ide drive.

    Any help appreciated.
     

    Attached Files:

  2. mode11 macrumors regular

    mode11

    Joined:
    Jul 14, 2015
    Location:
    London
    #2
    Have you tried booting from CD or from a FW drive? Can you put it in Target Disk Mode and check the disk with Disk Utility from another Mac? I'm pretty sure that red light comes on whenever the Cube's powered up, though could be thinking of a different LED.
     
  3. California macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #3
    Try booting from Tiger or Panther or Jaguar?
     
  4. HunterZ macrumors newbie

    Joined:
    Dec 11, 2018
    Location:
    Seattle
    #4
    Did you get anywhere on this? I have a G4 cube with a red DS2 LED also. It sounds like it boots up just fine, but the display doesn't come on (regardless of whether I use the Apple LCD or a VGA monitor).
     
  5. serdar13 thread starter macrumors newbie

    Joined:
    Jul 17, 2018
    #5
    Hi, haven't had to chance. Hopefully over the Christmas holiday period can try and sort it or at least do further testing.
     

Share This Page

4 July 17, 2018