G4 (Digital Audio) Power Supply dead?

Discussion in 'PowerPC Macs' started by YOLO, Oct 16, 2008.

  1. YOLO macrumors newbie

    Joined:
    Mar 21, 2008
    #1
    Hi all,

    I (my wife actually) has a G4 533 Digital Audio that won't start up. First, she booted the computer up and got the flashing question mark/mac icon suggesting it could find a start up folder. Instead of asking me she unplugged it to turn it off. When she tried to turn it back on, no lights, no fan, nothing.

    I have tried just about everything but testing the actual power supply. Apple has instructions for other models but not the digital audio. I finally tracked down the graphic Here that matches mine. Can anyone tell me what pins to test and what reading I should get on the multi-meter?

    Next, assuming it dead, anyone have a power supply they want to get rid of? :)
     
  2. fkntotalkaos macrumors 6502

    Joined:
    Nov 24, 2007
    #2
    try replacing the pram battery
     
  3. deadfrog macrumors regular

    Joined:
    Sep 5, 2004
    Location:
    UK / Bournemouth
    #3
    Bit strange, but my G4 Digital Audio died on me about a month ago... Just wont do anything when you press the power button... Tried various things with the pram, am guessing its the power supply now but haven't got round to buying a new one...

    I suppose they have a limited life span, but thought other stuff would fail before the power supply...

    I think you can get replacement ones on ebay for about £14 the last time i looked...

    Sorry I cant be anymore help
     
  4. YOLO thread starter macrumors newbie

    Joined:
    Mar 21, 2008
    #4
    Thanks for the reply's. I tested the pram battery and it's fine. So, know one knows how to test the power supply?
     
  5. Earl Urly macrumors regular

    Joined:
    Jul 11, 2004
    #5
    Buy an adapter from here:

    http://atxg4.com/

    And you can use many PC ATX power supplies that cost much less than what used Apple power supplies are going for. Some gotchas are some power supplies don't work in deep sleep, your Firewire ports can't be trusted to power any devices (you'll have to use a power brick)
     
  6. YOLO thread starter macrumors newbie

    Joined:
    Mar 21, 2008
    #6
    Thanks for all of the replies. I ended up buying a PS on eBay and got it swapped out. Now the power light will come on when pressed but nothing happens.

    Any thoughts?
     
  7. YOLO thread starter macrumors newbie

    Joined:
    Mar 21, 2008
    #7
    Never mind... I pulled the PRAM battery and put it back in and it fired right up! (gremlins). Thanks for all of your help!
     

Share This Page