G4 iMac airport card not finding network

Discussion in 'PowerPC Macs' started by kashimo, Sep 5, 2008.

  1. kashimo macrumors member


    Aug 13, 2004
    So here is the issue.
    My brother sent me a D-link AirPlus Xtreme G Router (802.11g) and an Airport card for my 800MHz PowerPC G4 iMac. (Running 10.4.11)

    I installed the card. No problem
    I connected the LAN cable from my NTT ADSL modem to the router.
    Turned everything on. NOTHING
    This is when I decided I would contact my brother.
    We chatted but things were still not working.
    I pulled out my MacBook. The Macbook found the router. I configured it for our system and my macbook was on the network.
    We even went to the extreme of having me connect my laptop to my iMac via Firewire and by bro connect via Apple remote and try to determine things on his own.
    But after 4 hours....no luck.
    My iMac....still not finding it. Still not finding anything.

    Usually I can find a wireless network that is coming from someone else's apartment but my G4 doesn't find anything.

    Could the card be broken?
    Could the antenna broken?


Share This Page