g4 powerbook problem

Discussion in 'PowerPC Macs' started by brandonscott, Apr 13, 2006.

  1. brandonscott macrumors newbie

    Nov 26, 2005
    Bowling Green, OH

    I own a powerbook g4 titanium that does not have apple care on it that I'm aware of. I purchased it here through the good ol' SA Mart.
    1ghz DVI edition, and I'm having some problems with power after an incident.

    What happened is someone spilled water on my desk. [Read: Not on my computer, on the desk that my computer was on]. I'm guessing water got on the bottom of my laptop, messing with the battery, or some other internals. What happened next is the computer went kinda wonky, the screen went blue, and the mouse was replaced with an unrecognizable random pixel shades. I turned it off and waited and it wouldn't turn back on after about an hour.

    The next day I decided to carry my computer over to the tech building of my school. They said it was be fifty dollars to look at it and diagnose what's wrong with it, and then 80 dollars plus whatever the cost of whatever parts they need to buy. So I decided against it for now, thinking I may be able to fix it on my own without spending that much. Then I got home, plugged it up to see it worked just for *****, and it did!.. for about an hour.

    I was delighted that I even got a response from the power button this time, and I was able to login and surf the web, get on my instant messenger and everything I was able to do before the problem arose. And then, once I started up garage band (3 if that matters), and was doing some recording, and once the trackload made the CPU actually work, the computer just turned off and wouldn't come back on. However, the little LED that's on the back (that lets you know the computer is sleeping, and still on) was on. However, the computer would just not come back on through the power button.

    And that brings us to the current situation. I've tried resetting the PMU dozens of times. Leaving the battery out for a while, replugging everything back up. Also, when I press the button on my battery, it has one flashing light, which means the battery is severely undercharged, even when I know there is plenty of charged. If anyone has any money-saving suggestions, that'd be great. And I've actually thought of sending it into apple just to get a quote, or does anyone think going through my school would be cheaper?

    Any and all input would be great, thanks a lot.
  2. chaosbunny macrumors 68000


    Mar 11, 2005
    down to earth, far away from any clouds
    I think that your school will most certainly be cheaper than sending it to apple, but I don't know how much they know about macs. If it is indeed the battery you could try to take it out, plug your tibook in and try starting it without the battery. This works with albooks (have done it with mine) so I guess it should work with your 'book too.

    If it is not the battery, but some other internal component(s) fixing it will be quite expensive, no matter if your school or an apple store does it.

    Maybe let it rest for another day or so and try again. 1 hour is not very much to get the inside of your computer to dry.

    Good luck!
  3. MACDRIVE macrumors 68000


    Feb 17, 2006
    Clovis, California
    You could turn the PB upside down and remove the lower case half to see if there is any water in there. All you need is a #8 Torx driver.
  4. brandonscott thread starter macrumors newbie

    Nov 26, 2005
    Bowling Green, OH
    ill be trying this as soon as i get some torx.

Share This Page