G4 Powermac won't connect to internet

Discussion in 'PowerPC Macs' started by TheKeith, May 29, 2009.

  1. TheKeith macrumors newbie

    Apr 30, 2009
    Randomly my nice old G4 PowerMac, running 10.4 stopped connecting to the internet.
    Checking the Ethernet settings, it isn't seeing any information.

    My cable modem and router are both fine. The router is wireless, and computers receiving the wireless signal work fine. I hooked the modem up directly to the Mac, and it still wouldn't see it.

    I'm actually a little concerned about a virus or something.

    Has this happened to anyone else?
  2. zmttoxics macrumors 65816


    May 20, 2008
    If you can paste the following...
    -Screen shots of the gui settings
    -Output from this command in Terminal.app: ifconfig -a
    -Output from this command in Terminal.app: cat /etc/resolve.conf

    ... we can then proceed with helping you.
  3. Eric S. macrumors 68040

    Eric S.

    Feb 1, 2008
    Santa Cruz Mountains, California
    What do you mean by randomly? Sometimes it connects and sometimes it doesn't? How do you know your cable modem and router are fine? Have you tried power cycling them? Have you changed any router settings lately? What make of router do you have?
  4. fireshot91 macrumors 601


    Jul 31, 2008
    Northern VA
    Sure it can't be the ethernet adapter (For a lack of a better word) on your G4?
  5. TheKeith thread starter macrumors newbie

    Apr 30, 2009
    By randomly, I mean that one day I was using the internet just fine, walked away from the computer, walked back an hour later and the internet no longer worked.

    Yes, I power cycled the modem and the router. I removed the router from the chain entirely, hooking up the modem right to the Mac through Ethernet, no effect. It goes Cable Modem to Router, Router to Mac through Ethernet, Router to a Windows laptop and iPod Touch wirelessly.

    And the two devices that connect to the internet wirelessly through the router work just fine. So I know for a full fact that the modem and router are working fine.

    Thank you for the suggestions, I will post the results later.
  6. TheKeith thread starter macrumors newbie

    Apr 30, 2009
    It could be. I hope not.
    I can't afford a new Mac right now.
  7. aibo macrumors 6502

    Jan 17, 2008
    Southern California
  8. Eric S. macrumors 68040

    Eric S.

    Feb 1, 2008
    Santa Cruz Mountains, California
    Right. Well the only problems I've had with devices not being able to connect to the internet always had something to do with the encryption setting in the router. In that case one device would not work while others worked OK. It sounds like that is not your problem though, from the other things you describe.

    One thing you could try is that for a fairly small cost you can get a USB wifi stick from Asus (or probably other manufacturers). That would be on the theory that the ethernet on your G4 is the problem.
  9. TheKeith thread starter macrumors newbie

    Apr 30, 2009
    <my name>-power-mac-g4:~ keith$ ifconfig -a
    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
    stf0: flags=0<> mtu 1280
    inet6 fe80::203:93ff:febd:7f2c%en0 prefixlen 64 scopeid 0x4
    ether 00:03:93:bd:7f:2c
    media: autoselect (100baseTX <full-duplex>) status: active
    supported media: none autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,hw-loopback> 1000baseT <full-duplex> 1000baseT <full-duplex,hw-loopback> 1000baseT <full-duplex,flow-control> 1000baseT <full-duplex,flow-control,hw-loopback>
    lladdr 00:03:93:ff:fe:bd:7f:2c
    media: autoselect <full-duplex> status: inactive
    supported media: autoselect <full-duplex>

    <my name>-power-mac-g4:~ keith$ cat /etc/resolve.conf
    cat: /etc/resolve.conf: No such file or directory

    Attached Files:

    • pic.jpg
      File size:
      199.4 KB

Share This Page