g4 quicksilver startup problems

Discussion in 'PowerPC Macs' started by bfreer, May 25, 2008.

  1. bfreer macrumors newbie

    May 24, 2008
    Please help me
    my G4 quicksilver has resently decided that it doesnt want to work. when i press the power button the light and fans come on but then cut out again after about a second. any ideas?
  2. bartelby macrumors Core


    Jun 16, 2004
    I had a problem similar to that with my QS. My problem was that I had too many buss powered USB devices connected to a PCI USB2 card.
    Have you tried resetting the PMU (a little button on the mother board, right next to the internatl battery)?
  3. bfreer thread starter macrumors newbie

    May 24, 2008
    yer i tried it a few times with no luck :(
    and i have now pulled the machine out from the desk so nothing is plugged into it apart from the power and monitor
  4. macsg macrumors newbie

    May 12, 2009
    G4 quicksilver startup problems

    i had the same problem and i tried almost everything.
    it resolved itself by imobilising the big fan with a pensil (under the power supply) for a second or two, while starting up.
  5. mr1970 macrumors member

    Feb 15, 2008
    Have you checked the voltage on your PMU battery? Replacing that will cost a couple of bucks and has worked for me on two different machines.

Share This Page