g4 quicksilver wont boot

Discussion in 'PowerPC Macs' started by fsx87, Jul 22, 2009.

  1. fsx87 macrumors newbie

    Joined:
    Jul 22, 2009
    #1
    i recently obtained a free quicksilver g4 from a guy, but it will not show video on bootup. I have tried each stick of RAM individually, i have replaced the prm battery, pressing the cuda button (but not multiple times, as everyone says it will drain the battery). Basically when i turn it on, there is a solid red light on the board, and the power button does a flash sequence of 1 long, 3 shorts. i have tried to look up what the power button flash sequece means but i no luck. I tried putting a diff video card in but it wont even turn on w/ a different agp card in besides the one that came w/ it :/

    ive never owned a mac and would love to get this thing working if i can, any help is appreciated :D
     
  2. OrangeSVTguy macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #2
    Sounds like the logic board might be gone, which is why I can see why it was free. Anyways, the red light indicates the memory is there/OK. Did you try putting in another Mac AGP card? The Macs need one that is compatible, any old PC video card won't work unless you flash it with the appropriate Mac rom.
     
  3. fsx87 thread starter macrumors newbie

    Joined:
    Jul 22, 2009
    #3
    some people said it might be the front panel board but i dont see how that could be seeing as it boots up, just no video. i havent tried another mac agp card because i dont have one nor can i get one locally. do you know where i can get a new motherboard for a decent price?? a working one preferably :p
     
  4. Dave H macrumors 6502

    Dave H

    Joined:
    Mar 2, 2008
    Location:
    California
    #4
    It seems to not like, or not detect, the RAM (may still be a bad motherboard).
    http://discussions.apple.com/thread.jspa?threadID=1949509&tstart=44

    I don't know about finding a new motherboard, but you can get a used onehere.
    I replaced my G4's motherboard with a used one about a year ago for about $30 and haven't had any problems.
     
  5. Firefly2002 macrumors 65816

    Joined:
    Jan 9, 2008
    #5
    I don't think so... he said 1 long and 3 short beeps. Doesn't that mean 4 beeps?

    1 beep = no RAM installed
    2 beeps = incompatible RAM types
    3 beeps = no good banks
    4 beeps = no good boot images in the boot ROM (and/or bad sys config block)
    5 beeps = processor is not usable

    If so you might be SOL if it's a bad ROM (never heard of that even happening). Not sure what the sys config block refers to, would assume PLL settings but the QS have that soldered onto the CPU nothing part of the logic board.

    You probably do need a new MoBo.
     

Share This Page