G4 Quicksilver won't sleep

bartelby

macrumors Core
Original poster
Jun 16, 2004
19,794
4
I've done a quick search of the forums but can't come up with anything.

Over the weekend my G4 Quicksilver decided that it would no longer go to sleep.
The second internal HD spins down, the display switches to stand by (eventually) but the main drive stays spinning. The only way to turn it off is holding the power button down.
I haven't added anything new, nor removed anything.

I've repaired the permissions and zapped the PRAM.

Anyone got any advice?


Thanks in advance...
 

Mechcozmo

macrumors 603
Jul 17, 2004
5,215
2
1. Disconnect all USB/FW devices that are not needed.

If it sleeps, add them back one by one until you find the one that causes it to not sleep.

-OR-

2. Restart and try above

-OR-

3. Try pressing in Power Button quickly, so it makes contact but just for a second. (Should sleep it)
 

bartelby

macrumors Core
Original poster
Jun 16, 2004
19,794
4
Sorry I should have mentioned I've already tried disconnecting everything except the keyboard (USB) and my iPod Dock (FW), I can't seeing these causing a problem suddenly as they've been connected since November.

Still nothing, I've also tried after a restart.

And using the power button just does the same as choosing 'Sleep' from the menu or allowing the computer to put itself to sleep, i.e. it doesn't.
 

Mechcozmo

macrumors 603
Jul 17, 2004
5,215
2
Check Activity Viewer (Applications/Utilities). Are there any weird programs running that may be stopping your sleeping? HP's Printer Utility I know caused some issues for me, and I wouldn't be surprised if others did too.

Are you running Classic? Maybe there is something in Classic?
 

alangyssler

macrumors member
Mar 5, 2005
74
0
Buffalo Grove, IL
Mine too!

I've had this problem for well over a year now, leading me to believe it's not a problem incurred from recent OS updates...

I've disconnected everything, no sleep.

I zapped the PRAM, and did that thing in the open firmware, no sleep.

I tried removing all additional RAM, and putting back the original 40 gig hd, and it still didn't sleep.

I tried wiping everything, and just installing a fresh copy of the OS, and again, still no sleeping.

I tried repairing permissions more times that I can count. No sleeping

I tried removing the two USB cards that I added in, and running without them. No sleep.

I tried putting on a 7 port hub for all my periphs, and disconnecting it when I wanted it to sleep. No sleep.

Tried replacing the battery inside the case, and still no luck.

I've tried just about everything I can think of... and still NO SLEEP for my Quicksilver 733 (2001)

My computer has the preferences unchecked for waking from sleep automatically. Still no luck.

Nothing screwy going on in the Activity Viewer, either. From what I can tell, that is...

By not sleeping, I mean I can select "sleep" from the Apple menu, and everything will power down, but them within seconds, it comes back to life.

I HAVE maintained sleep for several hours when running my computer from a Firewire external HD with OS 10.3.9 on it. But why would that work when nothing else has?

Please help. I hate haiving to turn my computer off at the end of the day so that it won't wake up in the middle of the night, and subsequently wake me up.

In short, dude I feel your pain. It sucks.