G4 suddenly refusing to boot in X!

Discussion in 'Mac Help/Tips' started by yamadataro, Jan 19, 2003.

  1. yamadataro macrumors 6502

    My G4 1G-DP MDD is refusing to start up in X!
    It was OK until a couple of hours ago, and now the start up gets stuck in the blue screen with X-style mouse cursor.

    Here's what I've tried:

    - Booted up in OS 9 and tried Norton and Disk Utility. They found some problems/fixed it but X is still refusing to boot.

    - David Pogue suggested moving OS9's fonts folder out of system folder since corrupted fonts could make X startup get stuck in the middle. I tried and no difference.

    - Tried starting up with Shift key holding down, but it doesn't recognize.

    - Zapped PRAM for 3 times in a row.

    - Tried starting up with Command-S to boot into command line and did "fsck -y". "The volume XXXXX apprears to be OK."

    - Clean-installed from the install CD which came with my MDD Mac. And it still is refusing to boot, what the hell???

    Would somebody please tell me what else I should try?
    I'm just so glad that this happened when I'm off from my projects for a couple of days... could have been a real mess if this happened in the middle of a busy day.

    FYI: OS X 10.2.3 has been installed on one partition and OS9.2.2 on the other. They are both on the same physical drive. OS 9 boots up OK.

    EDIT: I clean-installed with the "Archive and Install" option. I guess I can also try normal clean install, but I'll have to set up and move all sorts of files if I do that... I'll keep it until you guys have no other suggestions.
  2. ShaolinMiddleFinger macrumors 6502a


    Oct 12, 2001
    That's all the things I would have done. Final result: call Apple.
  3. TiWarrior macrumors member

    Jan 12, 2003
    Have you tried fixing OS X permissions? I only ask because I had the same problem a few weeks ago, and fixing permissions sorted it. What I had (stupidly) done was to make the ownership permissions of the hard drive to my user, not the system! So if the system wasn't granted access to the hard drive....nice blue screen!

    Hope this helps
  4. yamadataro thread starter macrumors 6502

    That sounds promissing.

    I actually did repair permissions by the Disk Utility. It could have caused some problems?
    Well, I'll try to find the command line way to change permissions and see what happens.

    EDIT: What I meant here was that I did use Disk Utility before this start-up problem. That permission repair might have caused this problem.
  5. TiWarrior macrumors member

    Jan 12, 2003
    Your right, it sounds promissing.

    Why not boot from the OS X CD and repair from there? That's what I had to do.

    If you do find a way to do it from the command line, make sure the system has read/write permission for the boot drive.

    Hope this makes sense!
  6. yamadataro thread starter macrumors 6502

    Oh, that's right. I forgot that installer has the access to the Disk Utility. It would be real funny though, if it end up as Disk Utility fixing the problem caused by the Disk Utility. See what happens...
  7. DaveGee macrumors 6502a

    Jul 25, 2001
    Okay while this might not do it...

    I want to share a problem that I had with a '1st gen AGP G4 450Mhz box'

    - Machine was running fine 'forever' hadn't shut down the box in like a year (reboots for updates but that was about it).

    - Went to install a larger HD so I shut the machine down.

    - Removed the old HD (tape backup 1st)

    - Installed the new HD

    - Boot from 10.2 CD and format installed the OS

    - Rebooted from HD and all hell broke loose... The Mac stated to boot but then I just got a 'grey screen' with a working cursor.... Never got a login screen.

    Tried everything!! to get the machine to boot zap the pram, re-reformat install X, reset the open firmware etc etc etc.... I even removed the new drive and replaced it with the old one (untouched) and the sucker still didn't boot!

    Well... it turned out to be the ATI VIDEO CARD!!!!

    After my 3rd re-reformat-install of the OS and it still didn't work, (I don't know why) but I pulled the video card and then reseated it...

    Turned the unit back on and BANG the sucker finished its boot cycle! I would have NEVER EVER guessed a re-seated video card would have fixed it but it did... Heck the CD booting didn't have a problem so why would a HD booting? To this day I dunno why but it worked..

    Hope this helps... (and if not you then some poor soul who has the same problem I did)

  8. Gus macrumors 65816


    Jan 1, 2002
    That's actually what I was going to suggest-make sure that your RAM and video cards are still seated properly. Take them out, and put them all back in again. I have never fully understood how those chips, being in a stationary desktop, could just come out of their sockets, but they sometimes do. Worth a try anyway.

  9. liven2 macrumors regular

    Jan 2, 2002
    Bonney Lake, WA
    mine wont boot this morning either

    I shut down last night,, And got up this morning and am getting the same things you are.. I am wondering if safari is causing this?.. Uhhg! I am bummed! I am running norton now. I have done everything that the original poster did except run NOrton.. it has been workign fine till today.. :mad:
  10. TiWarrior macrumors member

    Jan 12, 2003
    When you get a startup problem, it is always advisable to think of any settings you might have altered before the last shutdown/restart.

    My advice is to think back to what you last did on the machine. Did you alter some permissions? Did you alter something in the startup items or preferences?

    I'm not sure that re seating a graphics card really sorted anyones startup problems. More like the action of totally disconnecting the mac from the power supply reset whatever had developed a problem. Remember that power still runs through part of your mac when it is shut down, but still plugged in to the mains. A total power off sometimes cures many strange electronic problems!

  11. buffsldr macrumors 6502a


    May 7, 2001
    An extreme solution

    1) If you can get into 9, as you say, back up your data to another drive (buy one if you need to, as you can see, you will need an extra drive from time to time)

    2) Boot off your X-cd. go to disk utility and format your hard drive.

    3) reinstall your os.

    good luck
  12. yamadataro thread starter macrumors 6502

    OK, so I've done permission fix (by Disk Utility and on the command line both) and unplugged and plugged video card and memory. I also swapped video card with my older G4.

    Oh, and I've also followed instructions in Apple's KnowledgeBase for the blue screen issue. Didn't work.

    So it looks like I have to try a clean-install without the Archive and Install option. If that still doesn't work, I'll try formatting the disk...


    For now, I'm working on a Tibook 800 connected to a Cinema Display. This configulation is nice, but it's slow compared to my dead DP G4.

    I'll let you guys know about my journey from here.
  13. TiWarrior macrumors member

    Jan 12, 2003
    Just another possibility....if you have more than 1 RAM module, try taking out the extras. It is possible that a module may have gone faulty.

    Also, press command & V at re boot. This will display the Unix messages and might give you a clue as to where the problem occurs.
  14. yamadataro thread starter macrumors 6502

    Thanks again for your suggestion.

    When I did the video card, I've actually tried getting the non-Apple RAMs out (two 512MBs) and booted. Didn't work.

    I'll try the command+V...

    Well I'll try anything right now.
    I've never had this kind of never-ending bad problem in the OS 9 days!
  15. benixau macrumors 65816


    Oct 9, 2002
    Sydney, Australia
    yep. but you didnt have aqua either :D

    really, osx is how old??? 2-3yrs (not sure)

    os9s base is how old??? 10+yrs (not quite sure)

    really i have had only one prob. i forced a reboot under os9 whilst playing starcraft and i got stuffed. archive and install from jag. all solved.

    good luck.
  16. frescies macrumors regular

    Dec 9, 2002
    Los Angeles, CA
    Just curious... How often do you guys use "Classic" (in X, not booting into 9), and how is it set up?

    I have had reaccuring issues similar to the ones mentioned here and they seem to follow this patern:

    I can have as many partitions on my computer with as many combinations of X and 9 and everything works fine. I can boot into a 9 folder on any partition (ive played around with half a dozen partitions or so) and likewise with X. However, If I boot using a 9 folder that is also being used as the startup volume for "classic" things become VERY UNSTABLE. If I have to do a force restart, force quit, or sometimes just a plain restart.... WHOO BLUE SCREEN!- Or I will get stuck at startup with my computer frantically searching for a valid boot volume (if it gets that far.... it rarely does and if it does, option startup cant find one either).

    Even with 2 partitions, one with x and one with 9 everything is fine booting into either until I run "classic" off that 9 and then boot into it.

    (Reformat... Reinstall... Pout in the bathroom for a couple hours)

    I currently have 2 partitions: one with X and a very basic 9 system folder that I use for classic, and one with my 9 folder that I use to boot from (which has all my extensions and goodies and whatnot). This may sound insane to those of you who would never have 9 and X on the same partition but it works perfectly on mine (perhaps 3 partitions?.....).

    I donno.... Maybe this is related, maybe not. Thought I should share though since it sounds somewhat similar. If not don't yell at me for wasting space, I did mean well by it.
  17. yamadataro thread starter macrumors 6502

    All right. I've clean-installed from the Jaguar Install CD and X is running OK now.

    The clean-install with the option to move old user data didn't work. But when I used format and insall optio, it worked fine. I guess it means there were some corrupted/conflicting files somewhere in the OS.

    Now I just have to spend half my day to install all of my apps and updates. Uh, that's not exactly my idea of fun...

    Conclusion of this mess:
    There were some weird files affecting the start up of the OS, but none of the ordinary fix solutions have worked.

    Thanks again guys!
  18. frescies macrumors regular

    Dec 9, 2002
    Los Angeles, CA
    Hey if youre up for it....

    boot into 9, force restart, and tell me if it works :D. im curious....

    actually dont. Force restarting in 9 is scary
  19. yamadataro thread starter macrumors 6502

    I've installed all of my software back in, and the system is working as if nothing evil has happened. I'm a liitle bit worried about the same thing happening again though.

    I've realized that having OS 9 environment is a big plus just to fix the OS X environment. Uh, having OS 9 just to fix another OS is kinda funny though ;)

    Well, but the bright side to this whole incident is that I know much more OS X recovery stuff than before. Come to think of it, that's the exact same way I learned tons of OS 9 stuff.

    Good. Many woman friends of mine has Macs now, so I'm ready to show off when they get into troubles. I usually end up with expensive dinners with a lotta drinks down in Tokyo :D

    Dear frescies:
    Sorry. I've fixed my machine already and can't try your force restarting in OS 9 deal. Creating two OS 9 partitions sounds like a viable idea, although in my case, there have to be a single OS 9. There are copy-protected professional Japanese fonts that can only be installed on a single OS 9 folder. I use these fonts from OS X.
  20. TiWarrior macrumors member

    Jan 12, 2003
    I have a copy of OS X on another drive, just to fix my main copy! This might seem over the top, but it has helped me many times.

    Happy to hear you are up and running again Yamadataro.

  21. frescies macrumors regular

    Dec 9, 2002
    Los Angeles, CA
    Copy protected fonts!!!

    Ahhhhhh.... Tre bien!
  22. 000111one111000 macrumors regular

    Jul 23, 2001
    DeKalb, IL
    safe boot

    Remember to try Safe Boot mode too, that might help you save your files.

    Shut down the Mac, turn it back on, wait till just after the startup tone, and then hold down the shift key. When the grey screen with the Apple logo comes up, let go of the shift key, and X will boot in Safe Boot mode.

    Safe Boot will only boot certain kernel extensions, etc.

    This might help you in the future though, to save certain files/settings you need and stuff.

  23. yamadataro thread starter macrumors 6502

    Re: safe boot

    I did try safe boot in the very first round of recovery trials and failures. The machine didn't respond to the shift key. It reached the same blue screen.

    Thanks though! I'll difinitely keep safe boot on my list of things to do for my next occation... :D

Share This Page