G4 Tower - No video after installing a second HD

Discussion in 'PowerPC Macs' started by emjay247, May 12, 2008.

  1. emjay247 macrumors newbie

    May 12, 2008
    Hi Everyone,

    I didn't see any other posts with this particular problem. I hope someone may have some helpful advice.

    I've got a G4 tower that was upgraded from the original 867 processor to a Sonnet 1.8. It has caused a few headaches because of the upgrade, but has been running well for about 2 years.

    The original HD went bad and was replaced with a WD 80GB along with the processor upgrade. I use the computer as a print server for an Epson 9800 and also have it hooked up to a Digi 001 Protools audio interface that is limited to OS 10.3.9.

    Well, the hard drive was filling up fast and I wanted the G4 to work better with my work flow and network, so I had the idea of installing a second HD and having two operating systems on the same computer. The original WD 80gb would remain on 10.3.9 for the Protools interface, and the second WD 160gb would run Tiger or Leopard for Adobe CS3 applications and iTunes.

    I researched the idea and discovered that it would be possible, but my motherboard might limit the second WD 160gb to being read at 127gb. I could live with that so I went ahead and made the purchase. I also wanted to reinstall the original optical drive that the G4 came with since iTunes wasn't recognizing the upgraded Super-drive as a compatible burning device.

    After powering down the computer and removing all external peripherals, I opened the G4 case and dusted it out using a can of fast air. I then replaced the optical drive with the original apple CD-R burner and then inserted the second 160HD on top of the original master 80gb and connected the serial and power cables. I closed up the case and booted it up, heard the startup chime, and saw the power lights come on the tower and monitor. I left the room to attend to other business and when I came back 10 minutes later, there was no video displayed on the dual 17" Apple ADC screens.

    At this point I started to feel like I made a mistake by messing with something that was already working, but I knew that mostly everything was backed up. If it was a mistake it wouldn't be that bad.

    I started the process of powering down the computer and removing all external peripherals to open the case again. Everything looked fine inside, connections were good and secure. I thought it must be the Jumper configurations on the HD that was not allowing the G4 to boot or display video. I did some research online and discovered that Western Digital's in particular were picky with the Jumpers, so I followed the diagrams on the HD labels and made sure the original 80gb HD was at the end of the internal IDE serial chain.

    After closing it up and booting again, the tower or monitor would not stay powered beyond a couple seconds. I thought I killed it for good until it occurred to me that it could be a power issue now so I went to Radioshack and bought a new PRAM battery.

    This time opening it up I removed all internal 3rd party PCI cards and RAM, leaving only 1 512 stick in the first slot. I replaced the PRAM and the G4 tower and one of the monitors powered up along with the startup chime, but still no video display after letting it run for 20 minutes.

    Now I do not know what is wrong with the machine and am stuck as to how to trouble-shoot any further. Could it be the upgraded processor that isn't working with the second HD attached? Maybe the video card is broken or mother board is fried. Could I have fried both HD's accidentally? I can't see anything because the video is out which makes everything more difficult.

    I am reluctant to invest any more money on a video card or motherboard for this machine when I can find a working G4 MDD on my local Craigslist for around $300 - $400.

    The only problem with that solution is that I've witnessed first-hand how loud the power supply and fans are on those models, therefore nullifying my original plan of using it for a audio recording station. I would just assume move up to a PPC G5, but the Digi 001 Protools interface only fits the G4 PCI slots.

    Does anyone have any helpful advice or solutions? Any help would be appreciated.

    Here are the following specs to consider. I'm trying to get everything to work together or at the very least get my video back.

    G4 Powermac 867ghz upgraded to 1.8ghz
    GeForce4 Titanium Video card with DVI-ADC
    2 Apple Cinema 17" displays w ADC connectors
    Apple ADC - DVI converter
    3 sticks of 512 Ram
    80gb Western Digital Caviar 7200 rpm IDE, (master) HD with OS X 10.3.9 installed
    160gb Western Digital Caviar 7200 rpm IDE, (slave) second HD w/ OS X 10.4 or 10.5 hypothetically installed
    Original Apple CD reader/burner
    Protools Digi 001 audio interface (PCI)
    USB 2.0 (PCI)

    Willing to spend $300 - $350 to get it working or another G4. Otherwise I'll have to save up and consider a G5 PPC and a newer Protools Firewire interface.

  2. Firefly2002 macrumors 65816

    Jan 9, 2008
    Odd. Try unplugging everything and letting it sit for an hour or so to discharge everything. That includes the PRAM battery (and unplugging it from the outlet).

    Have you checked to see that the GF4 Ti is still seated properly in the AGP slot? I had that problem when I built a PC for my mom six or so years ago.. I hadn't seated the AGP card properly, so, no signal.

    Also, make sure you have the jumpers for BOTH drives correctly; if you've got both drives on the same IDE channel (cable), then one has to be a master, the other has to be set as slave. I don't think the Mac supports CSEL, either which might be default on some shipping drives. And yeah, I think WD might have a different jumper configuration than most other drives.

    I would have recommended getting a faster, 320 GB WD (with the two 160 GB platters), but oh well.

    It's not a power issue. HDDs take up hardly any space.

    Try disconnecting one of the monitors, though. Try to simplify things.

    It's also possible the IDE (ATA) cable is damaged. If all else fails, replace it.

    That's all I can think of right now.. time to start on my Sociology final due tomorrow :)
  3. emjay247 thread starter macrumors newbie

    May 12, 2008
    Problem Solved - Bad Video Card

    Problem Solved - It was the video card that stopped working at the same time that I added the second hard drive.

    Either it was a freak coincidence or I shorted it by not being grounded properly. A friend of mine had an old G4 350 mhz laying around that I was able to pull the video card from. I tested it in my G4 and viola! Video with no data loss at all.

    I still have to buy another video card to utilize both of my monitors, but at least I know now that it was the problem. Hooray!

    Now I have two hard drives and OS 10.3 AND OS 10.4 running on the same computer.

    Thanks Firefly2002 for your helpful advice.
  4. Firefly2002 macrumors 65816

    Jan 9, 2008
    You can't actually be sure that it's the video card... G4/350s came with PCI video cards... because they don't have AGP slots.. so you still might have the AGP card seated improperly, or some other such issue.

    Try things I've said before you attempt to buy a new one. Better yet, try your AGP card in another Mac to see if it's still working okay. It really might just be an issue you're having, not a bad video card.

    It's unlikely you've shorted it... I've been inside computers and stopped using a grounding strap a longggg time ago... don't even bother grounding myself on the PSU anymore..never blown anything. Video cards would be even harder than most things to screw up.

    It's also unlikely to be a freak coincidence, there's likely a reason.

    Point is, you might not have to buy a new video card. ;)
  5. CWallace macrumors 603


    Aug 17, 2007
    Seattle, WA
    Just a follow-up, based on the Apple User Manuals for my G4 QS and G4 MDD, both note that HDDs should use CSEL (Cable SELect). I have dual HDDs in both and am using CSEL.
  6. emjay247 thread starter macrumors newbie

    May 12, 2008
    The problem came back

    I was able to fix the issue by using a different video card. The only problem was that it had a single dvi port and I eventually was going to need a new card that supported dual monitors. I found a local seller using Craigslist, but before I wanted to commit to the purchase, I thought it would be a good idea to make positively sure my old video card was not working.

    I swapped the video cards and booted it up. My previous inclination to believe the part is unusable was confirmed by no video signal being produced. So I swapped the card back to the single DVI that had worked the same day and now there still is no video signal being displayed.

    My question is if there is something that needs to be done, a command or something to reset when switching video cards? I'm going to leave the equipment powered off and try again tomorrow.

Share This Page