G4 USB speed drastically slows down. Why?

Discussion in 'PowerPC Macs' started by gomtu, Jan 2, 2013.

  1. gomtu macrumors newbie

    Joined:
    Dec 15, 2012
    Location:
    Florida
    #1
    When I got this G4 MDD it had USB 1.0, which was unbearable for videos, so I got a TERMINUS TECHNOLOGY USB 2.0 card for it, and everything was peachy until two days ago, when I moved my five external drives and plugged them all back in to the hub, and suddenly I seem to be back at USB 1.0 again, with the data transfer speeds plummeting terribly.

    Now my videos take a long time to load, whereas before they were nearly instantaneous, and they often freeze up for 15 - 20 seconds or more. I tried to copy at 336 mb file from one disk to another, and it said it would take 22 minutes to do it! Not good at all! I know it was a LOT faster than that before. Writing any file to disk is far slower now, and I have no idea why, or what to do about it.

    So what might have caused this? I've never heard of such a thing happening before this.

    I'm running 10.5.8 Leopard. Suggestions and theories welcome.
     
  2. iThinkergoiMac macrumors 68030

    Joined:
    Jan 20, 2010
    Location:
    Terra
    #2
    If you have any USB 1 devices on the hub, that may slow the whole thing down to USB 1 speeds. Only thing I can think of.
     
  3. gomtu thread starter macrumors newbie

    Joined:
    Dec 15, 2012
    Location:
    Florida
    #3
    I think you have nailed it here, and I seem to have already found the problem, an older 500 gb USB drive on the hub. I disconnected this and the file I had previously tried to transfer then took 11 minutes to copy to another disk, half the 22 minutes previously.

    It was not a USB 1.0 drive, but it is very old, and I believe failing.
     
  4. Lil Chillbil macrumors 65816

    Lil Chillbil

    Joined:
    Jan 30, 2012
    Location:
    California
    #4
    That sounds right to me
     

Share This Page