G4 won't boot into Open Firmware

Discussion in 'PowerPC Macs' started by mark80, Jun 3, 2014.

  1. mark80 macrumors newbie

    Joined:
    Jun 3, 2014
    #1
    Hello everyone, I'm new on the forum.

    I have a problem with a G4 PPC Powermac that I can't figure out. Whatever i do, I'm unable to boot into open firmware. Not only that, but I can't boot from a CD holding the C key or go into "choose your booting" mode with the Alt key. I can't go into target firewire mode either.

    I've tried with another keyboard, I've tried disconnecting one of my HDs (I have two), I've tried with and without a mouse and with every USB port, but nothing will do. Whatever I try, the Mac just boots form the HD (and takes forever, too).

    This Mac is second hand: maybe the first owner did something weird to it? I have an old iMac and it will boot into open firmware with no problem. Any ideas?
     
  2. Mr Rabbit macrumors 6502a

    Mr Rabbit

    Joined:
    May 13, 2013
    Location:
    'merica
    #2
    It almost sounds like it has a firmware password, in which case it would ignore all of those commands. Except, of course, for holding option to bring up the Startup Manager. Holding option would instead bring up the password dialog.

    Still though, maybe try removing one of the RAM DIMMs and resetting the PRAM (wait until you hear it chime three times), this "should" clear the firmware password if one is indeed present.
     

Share This Page