G5 can't use Flash player

Discussion in 'PowerPC Macs' started by backlineimprov, Sep 16, 2012.

  1. backlineimprov macrumors newbie

    Sep 16, 2012
    Out of no where a couple weeks ago, I was unable to watch almost any and every video online, where I was able to watch almost everything the day before. Something is wrong here, right? I can only get Flash 10 with a G5, but even videos that need Flash 9 or higher aren't playing. Did something get lost on my computer or was Adobe really able to upgrade all internet videos over night? Any help or suggestions? My computer is only an email machine now.
  2. Boxeo718 macrumors newbie

    Sep 16, 2012
    I'm having the same problem as I am a G5 user. Apple, Flash and different browsers have stopped writing updates for PowerPC processors. So therefore we're pretty much screwed. Lately Hulu and any video player or Flash-heavy website have either crashed my browser or haven't worked at all. Strangely Youtube still works for me about half the time.

    People have written hacks that have enabled powerpc Flash 10 users to see Flash 11 content like this:

    However, this didn't work for me. But I'm glad that people are still trying to find ways to make Flash work for ppc users.

    Right now I'm using my phone for Youtube. I may wind up buying a cheap PC to go on the internet with for now.
  3. Zotaccian macrumors 6502a


    Apr 25, 2012
    Use YouView or Mactubes to view YouTube -content.

    I don't have Flash installed on my iBook G4 at all as YouView performs much much better. If I remember correctly, there was also this one plugin which opened YouTube -videos directly with Quicktime.
  4. Boxeo718 macrumors newbie

    Sep 16, 2012

    Thanks for that! I'm gonna check them out.
  5. tdbmoss macrumors 6502


    Dec 4, 2011
    The patches to make Flash 10.1 identify itself to websites as a newer version do work - recently the BBC site started demanding at least Flash 10.2, but worked again after I changed the version numbers within the Flash Player.plugin file from 10.1 to 11.4.

    Check that the plugin file is in /Library/Internet Plugins - you might need to try deleting it and reinstalling the Flash 10.1 package if your Flash isn't working at all; then if you get websites complaining that your Flash is too old, replace the plugin file with a patched one.
  6. orestes1984 macrumors 65816

    Jun 10, 2005
    If I'm going to youtube, I make sure its on the HTML5 page.
  7. Boxeo718 macrumors newbie

    Sep 16, 2012
  8. GermanyChris macrumors 601


    Jul 3, 2011

Share This Page