G5 Drive Storage Drive Upagrade Problems

Discussion in 'PowerPC Macs' started by VreXMedia, Apr 13, 2011.

  1. VreXMedia macrumors newbie

    Apr 10, 2011
    Houston, TX
    Hello guys,

    I recently purchased a G5 for my media development business. Being that most of our files are huge and we have a ton of clients, we need a internal storage drive with a lot of capacity so we purchased a 1TB 7200 RPM Seagate Barracuda drive to install as a 2nd drive. Our G5 DID NOT recognize it. I tried everything that i could research on the internet but it didn't work. We purchased the 1st drive from new egg. Since it didn't work, we went to Best Buy and purchased another 1TB 7200 Drive that read on the side of the box that it would work with Power Mac g5s. This drive didn't work either.

    Below is a list of my G5 Serial number and the model numbers to both of the drives. Please let me know if it is possible for me to get one of them to work.

    Thanks in advanced

    Model # S/N: Retailer:
    ST310005N1A1AS-RK 6VPBM6LJ (Purchased from BestBuy)
    ST31000524AS 6VPBWF13 (Purchased from Newegg.com)

    My Mac G5 Serial number is: G850538AQPM
  2. ascii42 macrumors member

    Feb 26, 2011
    I recently bought a new hard disk for my G5. Since the G5 doesn't have SATA 300, I had to put a jumper on two of the pins in the back to get the hard disk to switch to SATA 150. Your hard disk should be the same way. Did it come with a tiny piece of plastic with two holes in it? Check the manual, it should tell you where to put it.
  3. Hrududu macrumors 68020


    Jul 25, 2008
    Central US
    I've never seen that problem with my G5 towers. I'm using a Seagate ST31000528AS right now in mine as the boot drive in fact. SATA 3 and 1.5 shouldn't make any difference. Did you try the drive in the other bay to ensure it wasn't just a bad cable or something?
  4. VreXMedia thread starter macrumors newbie

    Apr 10, 2011
    Houston, TX
    Jumpers In Place

    Thanks for the input guys,

    I have not yet tried it in the other bay but i do have the jumpers set to 1.5. This is th second time someone has suggested that i switch the connections to see if the drive reads so i am going to do so to see what happens.

    Thanks for you response.

Share This Page