G5 hd problems

Discussion in 'PowerPC Macs' started by imKevin, Aug 25, 2010.

  1. imKevin macrumors newbie

    Joined:
    Aug 25, 2010
    Location:
    Austin, Texas
    #1
    I changed the permissions from read only to read and write on my start up HD and chose the change everything inside option to read and write. After I did this, my secondary HD no longer allowed me to use it saying I did not have permission. When I tried to change it all selections were in custom mode and would not accept my changes. Same with my main HD. I rebooted and the grey screen shows up with icon and no spinning wheel. I tried safe mode...same thing. I even tried booting off my back up firewire drive and got a null sign on the grey screen instead of an apple icon. Booted up from the G5 disk and tried to run utilities permissions repair and it would not do it, gave me an error, “No valid packages”. Ran disk repair and it said nothing needs repairing. I then booted up using Disk Warrior and rebuilt the HD’s directory successfully, but still the G5 will not boot past the icon grey screen, no spinning wheel. I’m spinning though...HELP, I'm dying here. FYI this is a G5 dual core Cypher running Leopard with 3.5 gigs of ram. The start up HD is 250 gig and the secondary is 500 gig
     
  2. Giuly macrumors 68040

    Giuly

    #2
    Insert Install-DVD or CD1, hold the "C"-Key on the keyboard while powering the machine on, select your language, choose Utils->Terminal from the Top-menu.
    Remember the Name of your start-up HD? I guess "Macintosh HD"?
    do this:
    Code:
    cd /Volumes/Mac*HD
    chmod -R 755 *
    Screws totally around with disk permissions, but makes everything readable again.

    It should boot up again, gather your files, backup them and reinstall the system.
    Next time, only screw with disk permissions of files which are yours.
     
  3. imKevin thread starter macrumors newbie

    Joined:
    Aug 25, 2010
    Location:
    Austin, Texas
    #3
    You can say that again

    I will never and I mean never make that mistake again. Before you responded a friend suggested an archival reinstall. I did that and the machine booted. However, every other internal and all firewire drives connected to the computer will not mount on the desktop. Using disk utility, all the harddrives are there, but the icon for what I have named them has changed to a piece of paper icon rather than HD icon. I even tried plugging the HD's in another computer and got the same results. I tried you suggestion and everytime I pressed enter after typing exactly what you suggested, terminal did not recognize the command. Also, I had to type it all on one line rather than the two lines your example shows. Every time I hit return to start a second line, the not a command line came up. I'm sure it is something I'm doing wrong. Please advise.
     

Share This Page