G5 mysteriously sleeping

zzlaz

macrumors newbie
Original poster
Jan 30, 2005
8
0
I have a brand new G5 that I am using as a server for a small office. I've attached our Epson to that machine locally and we are all printing to it on our LAN.

I have the preferences set so that the computer should never sleep or go into energy saver mode. However, it seems to be ignoring these settings. Even more strangely, it will stay awake and then promptly fall asleep as soon as someone sends a print job to it.

I am updating the Firmware right now and then I will reset the PMU. But I am very confused. Any ideas appreciated. TIA.
 

hotmaj

macrumors newbie
Mar 13, 2004
9
0
thermal runaway

sounds like a thermal runaway check your system log (apple -about this mac-more info- syslog) for the words thermal runaway if so it probably needs new cpus mine did ( getting it nack tomorrow see if it has fixed the problem)
same with others there is an internal apple article no 93988 which talks about the thermal runaway problem
 

Blue Velvet

Moderator emeritus
Jul 4, 2004
21,922
169
Panther Bug

This may be relevant or possibly not but best to eliminate this option anyway.

In the Energy Saver preferences – Sleep and Schedule – reset your settings the way you want them BUT don't click/close the lock...

For some weird reason, closing the lock seems to force Energy Saver to 'forget' its settings...
 

zzlaz

macrumors newbie
Original poster
Jan 30, 2005
8
0
thermal runaways

found some thermal runaways in the log. i just got this machine swapped because of a defective drive cable in the previous one. it's all of two days old you really think its the cpus?
 

hotmaj

macrumors newbie
Mar 13, 2004
9
0
100% its thermal runaway issue

yes mate if u found them in your log its definitely a cpu module or thermal sensor callibration problem ring apple and let them know that they have sent you another lemon. It really pisses me off that they have still not fixed this problem
 

Makosuke

macrumors 603
Aug 15, 2001
6,168
354
The Cool Part of CA, USA
zzlaz said:
it's all of two days old you really think its the cpus?
Unless you have it wedged into some sort of tiny cabinet with absolutely no airflow (you don't, right?), then yep, there's something wrong with the CPUs or their thermal sensor.
 

zzlaz

macrumors newbie
Original poster
Jan 30, 2005
8
0
is it worth running memtest or something similar before calling?
 

c0052350

macrumors member
Oct 10, 2003
38
0
get them or it replaced

just got mine back today they replaced a cpu not both tight sh*ts but the difference is amazing so far ( tough wood) it seems like a totally different beast no thermal runaways rendering 1080i hd footage - mpeg 2 in fcp hd with both cpus at full usage its very very quite actually the fans rev for a few seconds and then back to what they are like when cpu load is idle. the rendering took 40 odd minutes and the beast was very silent.
So for i can't replicate the thermal runaway problem.
my only concern is that one cpu temp is higher than the other (could still have a crappy cpu left) the temp difference varies 10-14 C between the two. My cpu 1 under full load never goes over 82c and cpu 2 never goes over 72c amazingly after the initial fan revs the system is quite as when its idiling with the hdd fan kicking in for about 4 secs now and again.
Now if i could get the other cpu changed it would somewhat put my mind at rest regarding the large temp difference by the way the idilng temps now are:
cpu 1 63c/145f
cpu 2 57c/134f

processor setting is highest
 

zzlaz

macrumors newbie
Original poster
Jan 30, 2005
8
0
applecare told me to do the same, but on a whim i figured i'd give it 24 hours with the processor setting switched down to automatic. worked perfectly - the log had been showing a thermal runaway just about every hour. now i haven't had one in 24 hrs. at least it buys me some time to decide what to do. thanks all who responded.....
 

hotmaj

macrumors newbie
Mar 13, 2004
9
0
just bides you time

i too found that running it in automatic helped but the problem was still there and sure enough running dvd studio pro brought it back so the best thing is to definitely get them replaced
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.