G5 not alive

Discussion in 'PowerPC Macs' started by davelange, Jan 22, 2009.

  1. davelange macrumors newbie

    Joined:
    Jan 22, 2009
    #1
    I have a G5 desktop that will turn on but won't initate. There is not ring (start up noise) and nothing shows up on the monitor. The fan progressively gets louder but the situation doesn't improve. I've tried starting it with out the case on but to no avail. This problem has happened a few times in the past year or so but when I hard powered it down it would start up again fine (happened rarely). I took it to the MAC store and the girl said it was my logic board. Just wanted to get some other feedback. Thanks.
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    That sounds like the motherboard. I hope you're under AppleCare.
     
  3. simie macrumors 6502a

    simie

    Joined:
    Aug 26, 2004
    Location:
    Sitting
    #3
    Try booting from the OSX CD and see if you can get the OSX to boot up.
    I had this problem a few weeks ago after running the latest upates.

    I was lucky as I have a second HD installed in my G5 and was able to install a new copy of OSX on this drive.
    This repaired the old OS and allowed me to try updating it again.
    I can now boot to either version of OSX and if 1 fails I can repair it easily without losing my already installed applications or data.
     
  4. Earl Urly macrumors regular

    Joined:
    Jul 11, 2004
    #4
    It could be the power supply, logic board, or the processor(s.) Can't understand why you'd trust the Internet over an Apple technician though
     
  5. OrangeSVTguy macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #5
    Some of those "Apple Geniuses" are not really the sharpest knifes in the butcher's block if you know what I mean ;).

    What model G5 do you have? Is it the last revisions with liquid cooling? See any corrosion damages or leaks?
    There was a repair program on certain G5 dual 2.0s and later and you can get a new power supply if it turns out it's not the processor(s) or logic board. Check here if your model falls within the specified serial numbers. http://www.apple.com/support/powermac/powersupply/repairextension/
     
  6. dallenmarket macrumors newbie

    Joined:
    Feb 1, 2009
    Location:
    Vegas Baby
    #6
    G5

    I had those symptoms and it turned out that a RAM DIMM had somehow become loose. shut everything down, pulled all of the DIMMS and put them back in. Worked for me. You might also try the same thing with the CPU card. A little inadvertent shaking/bumping has been known to pop cards loose.
     
  7. dophineh macrumors member

    dophineh

    Joined:
    Jan 29, 2009
    Location:
    California
    #7
    if this happened to me i would:

    (1st) try to boot from cd... if you can indeed boot from the cd, it is a software problem most likely.

    (2nd) if 1st failed, i would make sure all connections are solid, in and out of computer. i might even cycle the connections (pull it out, put it in).

    (3rd) still no workie? i'd be upset and realize that it is a hardware issue.
     

Share This Page