g5 ppc start up problem :(

Discussion in 'PowerPC Macs' started by 9Mills, Sep 22, 2011.

  1. 9Mills macrumors newbie

    Sep 5, 2011
    Upon start up I'm getting a folder w/ a blinking question mark/apple face

    This occurred randomly after I restarted one day and now I can't figure out what the heck the problem is.

    My research led me to believe my hard drive had failed so I went out and bought a Western Digital Caviar Blue 500 gb hard drive. I formatted it, etc and have installed Leopard on it. I have gotten it to start a couple of times but it's not consistent (when it did start up i updated it). Each time I still get the same thing. So now I'm wondering if I even needed a new hard drive in the first place :confused:.

    Can anyone help me with this?

    This is the type of g5 I'm using.

    I've tried pram resets. nvram. leaving it unplugged. running disk utilities. and I still get the same screen. Basically everything I have looked up is telling me that it can't find the boot drive is there a way I can make it recognize it?

    What originally happened was that disc utilities on the install discs (I have tiger and leopard) weren't detecting my old hard drive and it was making a ticking noise so that is why I got a new hard drive.

    I also ran a hardware test using my tiger disc and everything passed.

    I have also changed the battery with the same type of battery and that didn't help...I'm at a loss. I can't figure it out using the forum help etc.

    Any ideas what could be wrong?

    Thanks in advance...I would really like to resolve this problem myself because I am pretty poor and can't afford to take it anywhere to get fixed. If I am unable to fix it myself I may be forced to use this crappy dell computer I am posting from ha.
  2. 9Mills thread starter macrumors newbie

    Sep 5, 2011
    my bad i guess i posted this in the wrong area/forum? is there any way an admin can move it to the proper 'mac basics and help' area/forum?
  3. Nameci macrumors 68000


    Oct 29, 2010
    The Philippines...
    You are in the correct forum, be patient. Once some of the posters here got an answer for you, they will post it.
  4. tom vilsack macrumors 68000

    tom vilsack

    Nov 20, 2010
    ladner cdn
    have you tryed opening it up and reseating the ram?
  5. 9Mills thread starter macrumors newbie

    Sep 5, 2011
    I took out the RAM and put it back in. It was a little dusty so I dusted it off. I am still getting the same thing. When I first did it disk utilities couldn't find the hard drive so I did a PRAM reset and it came up. (while I was reseating the RAM I pushed the little SMU button and I had left it unplugged for the night)

    I went to system profiler to check if I had the correct RAM showing up and I have 1.5 gb which I think is correct because I think I have two 256 and two 512?

    I could write more about what I've done that is a short version. When I first wrote it...it was a wall of text so I kind of summarized it.
  6. MacSince1990 macrumors 65816


    Oct 6, 2009
    It sounds like you might have a failing SATA controller.. or possibly a bad port. Have you tried switching from the first to the second bay (and along with it, using the other SATA cable provided)?

    If it is the SATA controller, you might have to buy a PCI/PCIe SATA card.

    Can you boot from the Optical drive? It's on a separate, ATA controller, so if it's the SATA controller, you shouldn't have issues booting from CD/DVD.

    You might have to use an ATA (PATA/IDE) drive and boot off the ATA bus...
  7. 9Mills thread starter macrumors newbie

    Sep 5, 2011
    It boots from the Optical drive (my super drive) almost automatically (if there is a disc inside of it). If there is no disc inside it just gives me the flashing folder w/a question mark/face. If there is a disc inside it (one of my installation discs it will show the same screen for a few seconds then load off the disc or it will just automatically load the disc from the optical drive).

    When it boots from the optical drive I can run disc utilities, system profiler, etc. The new hard drive shows up (pretty stable but occasionally it does not show up usually a PRAM reset works to get it showing or just a 'shutdown' in startup disc utility then a restart) when I put it (the new hard drive) to start up disc and restart it just repeats the process.

    I have not tried the 2nd bay. There is only one 'tiny cord' coming out of there whereas the top has two one 'tiny' one and a slightly 'larger' connection (if that makes any sense sorry I don't know what they are called). When I disconnected my original hard drive both were connected and when I connected my new hard drive I connected both again.

    If I put it in the 2nd bay do I just connect the one 'tiny' one? or is there also a 'larger' cord somewhere stashed? The tinier one was kind of tucked in and I see it but I don't see the larger one.

    p.s. Thanks for the help so far guys :)
  8. MacSince1990 macrumors 65816


    Oct 6, 2009
    You know you might want to replace the PRAM battery, too.

    Anyway, I promise you there are two of each of those cords (the "tiny" one is the SATA data cable, the big one is the power cable ;) ), you might just have to poke around to find it as it can get caught behind the structure sometimes.

    It's starting to sound like the SATA cable or controller is bad. Test the other one! :)
  9. 9Mills thread starter macrumors newbie

    Sep 5, 2011
    Okay. I found the power cable it was attached to the first one there are two on the same cord so I just extended it and connected the wires.

    I put the drive into the second bay and the same thing occurred. However now my optical drive is being retarded and keeps spitting out my installation discs grrrr. (or anything I put into it)

    So...I started holding 'option' and to my astonishment the drive was there! I loaded it up and everything seemed fine but of course I didn't want to jump the gun so I restarted. Unfortunately the same screen appeared. I restarted holding option...the drive was there again...I went to system preferences and to my startup disc then I put the drive as startup and restarted. The same flashing folder face/question mark appeared.

    I restarted again and held option and it is being 'sporadic' at best. Sometimes the hard drive appears and sometimes it doesn't...

    I mentioned earlier that I had changed the PRAM battery. Under closer inspection I noticed that the little top connection wasn't touching the battery. So I fixed that and the same thing keeps occurring.

    I'm going to try to fix the optical drive by running a disc cleaner in it (that usually works whenever it decides to be crazy) and try to repair permissions and stuff while it is in the 2nd bay. Maybe that will work? I don't know. Just giving an update. Thanks again for the help so far :)
  10. 9Mills thread starter macrumors newbie

    Sep 5, 2011
    Okay I tried repairing permissions and doing all the things the guides say like reinstalling my OS etc. and I think I'm going to have to agree with you that it's the SATA Controller or cables.

    Is there any way I can narrow it down? I noticed my bottom Sata cable (the bottom bay) has a little 'tear' in it. Would that prevent it from properly loading? If not then I'm supposing that when I switched the bays and it's still not loading 'most of the time' then that means it's the controller right?

    Also am I going to have to remove anything or do I just 'void' the 'old' connections and put in the new controller and use it's connections?

    Are there any certain ones (Controllers)I should be looking at? I don't know how to 'narrow' down my search on google...any suggestions for keywords?

Share This Page