G5 Quad in Classic makes fans take off

Discussion in 'PowerPC Macs' started by Khristyjeff, May 27, 2019.

  1. Khristyjeff macrumors newbie

    Joined:
    Mar 16, 2017
    Location:
    Illinois
    #1
    Hello all. Just picked up a G5 Quad in excellent condition. I need this machine for some old software I use for my business. I swapped out the hard drive from my ailing G5 2.3 (from early 2005). The Quad is from late 2005.
    It boots up and works great except when I open up an app in Classic mode, the fans start to take off. When I close Classic, the fans go back to normal.

    I'm running Apple Hardware Test and everything checked out fine but has been working on the 8gb ram for a long time.

    Any help you could give me would be greatly appreciated.
     
  2. Dronecatcher macrumors 68030

    Dronecatcher

    Joined:
    Jun 17, 2014
    Location:
    Lincolnshire, UK
    #2
    Some Powermac G5s are more noisey than others - I had a Dual 2.3 that behaved like your Quad, I got round it in Preferences, adjusting the performance setting to lowest, although that meant the CPUs were operating at a lower speed it's stopped the fans revving up.
     
  3. fourbirds macrumors newbie

    Joined:
    Jan 12, 2019
    #3
    Verify what the idle temps are using iState menu from the PPC App store. Maybe the temps are already right on the edge before a partial CPU load spikes the temperature while using Classic.
     
  4. Khristyjeff thread starter macrumors newbie

    Joined:
    Mar 16, 2017
    Location:
    Illinois
    #4
    Thanks for responding so quickly. I'll get iState but for the moment I'm still waiting on hardware test to finish. It's been 3 hours and 20 minutes and counting. It's been on Memory for ever and I only have 8 Gb. Should I just stop that and continue with iState or do you think it's worth waiting awhile longer? Thanks again.
     
  5. eyoungren macrumors Core

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    ten-zero-eleven-zero-zero by zero-two
    #5
    Just for the record…it's iStat Menus, not iState. You may have trouble finding it looking for iState.
     
  6. Khristyjeff thread starter macrumors newbie

    Joined:
    Mar 16, 2017
    Location:
    Illinois
    #6
    OK. I loaded it and the hottest idle temp registered is the cpu at 59 degrees and once starting Classic the temp went to 78 in CPU B core 1 (and that's with fans blowing). So is that why fans are picking on?

    Also, where do I find the preferences where I can set the performance setting to lowest? Thanks again.
    --- Post Merged, May 27, 2019 ---
    I Changed the Processor Performance from Automatic to Reduced in the Energy Saver Pane in System Preferences (Thank you Dronecatcher). I measured the temps using iStat menus (thank you eyoungren and forbids) that reduced the temp in CPU B Core 1 to 50 degrees so no fans turned on high. Problem solved!

    Thanks again for sharing your expertise.
     
  7. fourbirds macrumors newbie

    Joined:
    Jan 12, 2019
    #7

    Attached Files:

  8. eyoungren macrumors Core

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    ten-zero-eleven-zero-zero by zero-two
    #8
    No knock on you, I didn't realize that. I don't use the PPC app store so I didn't know.

    They should fix that though. Bjango makes/sells iStat Menus, not iState.
     
  9. XaPHER macrumors regular

    XaPHER

    Joined:
    Oct 13, 2010
    Location:
    Nowhere to be found
    #9
    AFAIK having classic running prevents (at least one of) the CPU threads(s) from going into nap state when idle. Likely related to how Mac OS handles CPU load in comparison to the mach kernel in OS X. All my machines produce more heat with classic running.

    I once tried something that seemed to work. Installed CPU director (1.5f6 ?) extension and control panel in classic folder, tried to open the control panel but OS X refused to, so I copied the CPUdirector prefs file from my "true" Mac OS 9 boot system to my classic prefs folder. The prefs file already had CPU nap enabled in it, and that really did seem to prevent CPU temp from going up all of a sudden on my MDD.
     

Share This Page

8 May 27, 2019