g5 unbootable, need uregent help!

Discussion in 'Macintosh Computers' started by tirion, Jan 9, 2005.

  1. tirion macrumors newbie

    Jul 30, 2004
    My 2.5ghz G5 has been behaving rather strangely after the recent firmware update. Firstly, perhaps 2 days after the update, the g5 crashed. The system was completely frozen, force quiting would not work so i had to do a hard restart. Upon rebooting, I was taken to an open firmware screen with an "invalid memory access" error. I then tried various things, booting in to single usermode, verbose mode, safe mode, none of these things worked, always bringing me back to the open firmware screen with the same error. I then attempted to reset pram as well nvram to no effect. Occasionally, after reboot, I would face the same grey screen but instead of the memory error, i get a decrementer error?! Running the hard ware diagnostics disk works( about the only consitently bootable disk now..), but on any one of the tests, the g5 hangs when scanning the memory, logic board and everything else check out fine. I can't boot from any other cd, each time it would hang and take me to the open firmware screen. The funny thing is, when i attempted to boot from the os x install disk 1 the first time, it would not work, but latter, it suddenly did! I managed to run disk utility and fix the file permissions and disk structure several times and successfully booted in to os x. Everything seemed fine for about a day....until it crashed again! The g5 behaved in the same way as it did above, defying any apple help document i have come across, even a google search would not help... Then, all of a sudden, in the middle of a call with apple care, the computer started working fine again. It booted perfectly, we even tried to run the apple diag cd and this time, the scans were completed perfectly. The test showed that memory was fine?! Even the apple tech did not know what happened, all attempts at diagnosing the g5 appeared to fail, with the g5 either displaying a blank screen or the open firmware one. Once again, the computer appeared fixed. Till it crashed yet again! I have not experienced a miraculous boot for 2 days now, and in urgent need of the information on the computer. I spent alot of money on this machine and, a couple of months old, gives me major problems. Even my 3 year old gateway is still functioning and has not given such catastrophic problems. I have added nothing extra to the g5, everyting is oem, this is the replacement unit after my first 2.5 g5 had a logic board error.... What happened to the quality I thought macs were know for? I really need a fix, or at least a proper diagnosis, bringing it in to an apple centre will take valuble time, time I cannot to waste. Please help!

    System stats
    2.5 ghz g5
    512mb apple ram
    160gig drive
  2. BakedBeans macrumors 68040


    May 6, 2004
    What's Your Favorite Posish
    ok, having a problem doesn't mean your mac is junk,
    you have got a quality machine,

    if you tried the usual loads of stuff just try an archive and install ( im by no means a hardware expert )

    see how you go, sorry you had problems, but it is rare to have two problems in a row like you have

    sorry i cant be more help,
  3. Blue Velvet Moderator emeritus

    Jul 4, 2004
    Just on a sidenote...

    If you have a long post, please try and break it up into paragraphs.

    It's much easier to read it that way... I get about 8-9 lines into your post and it starts to get a little confusing and difficult to read. Thanks.

    p.s. Could it just be a bad memory module? Hard to check when you need to keep a matching pair in there...
  4. simie macrumors 6502a


    Aug 26, 2004
    Resetting the Pram

    Press and hold the Command-Option-P-R keys.

    You must press this key combination before the gray screen appears.

    Hold the keys down until the computer restarts and you hear the startup sound for the second time.

    Release the keys.

    or if the rest PRAM does not work try and go into the open firmware by holding down Command-Option-O-F key combination during startup here's how.

    When you hear the startup sound, press and hold the Command-Option-O-F keys. (The Command key has an Apple on it.)
    Release the keys when you see a white screen that says "Welcome to Open Firmware."

    Then type


    Press Return

    Then Type


    See if the mac will boot for itself if not then reset it.

    Once the Mac has rebooted hold down the Press Option-Command-Shift-Delete during startup to get the firmware to search for a boot device.

    Failing that go back into the open firmware and type


    If that fails then type reset-all to reboot.

    If that does not work then I would contact Apple and get them to fix the problem for you.
  5. Mechcozmo macrumors 603


    Jul 17, 2004
    Did you take out all non-Apple RAM before you ran the firmware updater?

Share This Page