G5 upgrade to 10.5 killed my airport card

Discussion in 'PowerPC Macs' started by roddenberry, Jul 30, 2011.

  1. roddenberry, Jul 30, 2011
    Last edited: Jul 30, 2011

    roddenberry macrumors newbie

    Jan 25, 2009
    Hope you can help me with this problem. I decided over the weekend to upgrade my G5 dual processor 1.8 tower from OS 10.4 to OS 10.5.8. (a clean install from the OS 10.5 disk to a new 1 TB drive). I also doubled my memory.

    So far everything went well, systems runs flawlessly, all apps are working and it runs pretty fast. But when I went into the "Airport Utility" app, the card was not recognized!

    The airport extreme card was running flawlessly under 10.4.11

    I did update the OS 10.5 to the very latest version available through an ethernet cable. I really need the airport extreme card to work because the 20 ft ethernet cable through the house is a real problem.

    Is there an update or a special driver needed? Hope I can resolve this situation because I would hate to downgrade back to 10.4!


    EDIT: IT WORKS !!!

    I finally got the Airport card going in my mac... but it was a pretty circonvoluted way!

    I noticed that the airport menu item on top of the screen mentioned "airport not configured", and when I pulled the card, it said "No Airport device found"... so I figured that the Airport card is indeed detected by the computer.

    I then looked at the Network control panel and there was no mention of the airport network... just below the list of the available network there is a little plus sign, which is the "create a new service" function. I clicked on that... Ta Da!!! Airport appeared but no network is chosen.

    So I chose my router, which has WEP encryption, and wrote my password in the field. No go. It wouldn't accept my password. I tried my laptop and my PC and both connected instantly. What could be wrong? Why doesn't it accept my password?

    So I connected my laptop to my router (a D-Link router) and disabled the WEP password, my network was then wide open with no password.

    Went back to the G5 and tried to connect to my wireless through Airport. After 3 or 4 clicks on the connect, the light went green and it connected!!!

    Finally, not wanting the network to remain wide open. I shut down my G5 and reactivated my password in the router. After restarting the G5, I selected my network, entered the password, clicked on OK... no go. Entered it again and clicked OK and it worked. I am now back to my wireless connection and everything is working 100%.

    So why was it so damn complicated to get it to work? Someone with less computer knowledge and perseverance would have probably given up long ago...


Share This Page