G5 wifi login getting "see administrator" message

Discussion in 'Mac Basics and Help' started by laemmle, Oct 8, 2012.

  1. laemmle macrumors newbie

    Joined:
    Oct 8, 2012
    #1
    Hello,
    I live in a house where we all log in on the same wifi network.
    The network has a WPA2 personal password. (PHY Mode 8.02.11n)

    I'm able to login easily on my Mac book Pro (OS 10.6.8) as well as my iPhone 4.

    But when I try to log in on my G5 Dual 1.8 Ghz power PC I get the message "see administrator" and I've searched and tried many solutions to no avail, including deleting and reinstalling the wifi network in network settings, deleting old preferred networks and resetting the PRAM.

    the G5 specs are OS 10.5.8 with an airport card (extreme 0x14E4, 0x4E) Firmware version B CM43xx 1.0 (4.170..)

    If anyone has any suggestions they would be greatly appreciated!

    M
     
  2. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #2
    I'm just guessing, but maybe that particular Airport card in the G5 can't handle WPA2. I've definitely seen some PowerBooks that can't do WPA2.

    One way to test this is to temporarily change the wireless network to use WPA, then see if the G5 connects.

    And you should check Apple's website for firmware updates to that Airport card.
     
  3. laemmle thread starter macrumors newbie

    Joined:
    Oct 8, 2012
    #3
    chown,
    Thanks for the response. I tried the firmware update fix. It didn't work. will try the WPA password and let you know what happens.
    M
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    All G5's can connect to a WPA2 network because G5's only take Airport Extreme cards. All of which can connect to a WPA2 network. They also don't have firmware updates. As the firmware is loaded at boot because they are Broadcom cards. Thus, if Apple was to update the firmware, all they'd have to do is release an update for Mac OS X's firmware directory for the cards. If you're already running 10.5.3 or newer, it's up to date.

    Make sure the antenna is correctly connected to the back of the PowerMac and to the card on the inside. Also, try removing the encryption on the network and see if it will connect. Lastly, try temporarily changing the password to something else.
     

Share This Page