Game flashes on my Macbook Pro (Video of problem), help?

Discussion in 'Windows, Linux & Others on the Mac' started by morgothaod, Mar 2, 2010.

  1. morgothaod macrumors regular

    Joined:
    Aug 26, 2009
    #1
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Don't play the game???


    Can you give us some more information, for example what kind of MBP do you have, what Mac OS X and Windows version exactly are you using, what drivers for the graphic card are you using, is the game updated, .... and so on.

    Is it only that game?

    What about changing some settings?

    What steps have you taken til now?
     
  3. morgothaod thread starter macrumors regular

    Joined:
    Aug 26, 2009
    #3
    MAC OS X Version 10.6.2

    MBP 2.53 ghz 4gb ram NVIDIA 9400M (Aluminum macbookpro)

    Windows 7 Home premium 64 bit

    Video card has latest driver

    I also get the flashing for Soldiers of Fortune 2 Double Helix: Multiplayer demo on full screen. When I don't have it on full screen, it doesn't flash.

    For Tribes 2 (game shown on youtube), it had crashed on me and I let Windows 7 fix the problem w/ "Try Recommended Settings"

    I'm not sure what it did, but the game hasn't crashed on me. But then again, I haven't played it for longer then 2 minutes.

    If you need any more info, tell me. I'm not good with computers so if you could tell me where to find the info, I'd appreciate it.

    I'll try and mess around with the in-game settings.

    I also play Quake Live and I have no problems with any flashing.
     
  4. akswun macrumors regular

    akswun

    Joined:
    Dec 29, 2009
    #4
    Sounds like the settings... I had to fiddle with my settings for Counter-strike 1.6(I know 1.6!!! not even source) I have the exact same MBP that you have...

    If it is possible change your in game video settings to D3D... I believe theres a problem with OpenGL with the MBP.... someone correct me please!

    But yeah make sure the video settings are not in OpenGL and things should be smooth from there.
     
  5. morgothaod thread starter macrumors regular

    Joined:
    Aug 26, 2009
    #5
    It appears you are right but...

    Tribes 2: I changed the setting from opengl to D3D and the flashing lines disappeared when the game was loading. After the "loading mission" and
    "loading objects" bars completed, I got into the game for 1/2 a second and then it froze.

    "unhandled exception: c000005
    at address: 02a35416"

    "tribes2 launcher mfc application has stopped working. A problem caused the program to stop working correctly Windows will close the program and notify you if a solution is avaliable. [Close Program]"

    I closed the program and it never notified me of a solution avaliable LOL. How long does that take? A week? :p

    For Soldiers of Fortune 2 Double Helix: I did not see a D3D option in the game settings. I changed the game settings and I still got flashing lines. Like last time, the flashing lines went away when I opened the game in a small window (not fullscreen).
     
  6. akswun macrumors regular

    akswun

    Joined:
    Dec 29, 2009
    #6
    this is where the tinkering happens... it took me a couple resets of steam and to finally get everything right... are you playing on your MBP screen or an external monitor(highly suggest! got a 23" LG running)... correction I checked your video again and you are running it off your MBP...hmmm... I can see where the problem exists...

    Make sure your screen ratios are set up properly... I swear I spent a while getting it right... once you get it right don't even think of touching the settings again!LOL..... I don't play any of those games that you're having problems with and I'm sure you're fiddling with the settings like crazy....

    I only play off of Steam... so I hope you find a fix because I know how frustrating it could be not being able to play games that ran perfectly on a PC....

    Get a second LCD! or I'm sure you probably have a VGA monitor somewhere and get the adaptor... best investment I've made!
     

Share This Page