[Gaming]Most Wanted 2 on rMBP

Discussion in 'MacBook Pro' started by Eduardboon, Oct 30, 2012.

  1. Eduardboon, Oct 30, 2012
    Last edited: Oct 30, 2012

    Eduardboon macrumors regular

    Joined:
    Jul 17, 2012
    #1
    So I tried to play Most Wanted 2 on the Base Retina..

    Well, even on 1680x1050 on LOW it stuttered like hell. Fraps gave me 60fps, but still stuttery, jittery gameplay. Anyone else that has this game and these issues?

    I've got the same issues with Skyrim, indoors it plays fine, but outdoors it's jittery as *****. Really disappointing as some people can play it just fine. I'm using 64bit Win7 Bootcamp for this.

    To clarify: even the scrolling text in the loading screens is jittery. Very very annoying. 1440x900 also doesn't work proper, no difference between 1440 and 1920 here.

    Also, BF3 doesn't run that well on 1680 either, whenever you start to shoot things feel laggy. Weirdly enough before I ahd this mac (this is a replacement) I had one that could play bf3 on 1920 just fine. I don't really care for that resolution though as 1680 is fine with me, but it's a bit strange.
     
  2. Newfiejudd macrumors regular

    Joined:
    Jul 8, 2010
    #2
    Reset your SMC / PRAM on your mac.
    Second Download Throttle stop, and disable turbo boost.
    Also download Lubbo's Fan Control and set your Fan speed to max.

    Also utilize Nvidia Inspector if you wish to overclock your GPU.

    Hopefully that will get you gaming with your new laptop.

    You can search the forums here for each one of these programs.
     
  3. Eduardboon thread starter macrumors regular

    Joined:
    Jul 17, 2012
    #3

    Thanks for your reply! I'll start testing this after work :)
     
  4. jvpython macrumors 6502

    Joined:
    Aug 25, 2011
    Location:
    New Zealand
    #4
    Also you could try benchmarking your GPU with cinebench just if you want to make sure it is working fine. The rMPR gets around 35fps in cinebench
     
  5. Eduardboon, Oct 31, 2012
    Last edited: Oct 31, 2012

    Eduardboon thread starter macrumors regular

    Joined:
    Jul 17, 2012
    #5
    Ok, I got 42FPS with cpu at 100 percent, at 95 percent I get 31 FPS. What can I do about this?

    Alright, I downloaded throttle stop but could NOT disable turbo. Therefore I just put CPU at 95 percent in Windows itself. Then I fired up Lubbos and most wanted 2 again, Now I could actually play! there is still jittery stuff going on that annoys the heck out of me, but it plays a lot nicer (especially at 1440x900!)
     

Share This Page