Gaming Problem with Parallels & VMWare Fusion

Discussion in 'Windows, Linux & Others on the Mac' started by mikeyPotg, Apr 28, 2009.

  1. mikeyPotg macrumors 6502

    Joined:
    Mar 20, 2006
    #1
    Hi guys,

    I recently installed UFO: Extraterrestrials (a 2 year old game) on both Parallels & VMWare Fusion.

    On Parallels - at first the mouse wasn't responding, so I did some thing where I disabled some ports and then the mouse worked. However, now, wherever the mouse is, it puts a long horizontal line across the entire screen. I tried to play with it, but it just started giving me a headache seeing the long black line everywhere I moved the mouse.

    On VMWare Fusion - it installed and runs great! However, the opening cinematic doesn't play (which I could get over) and the animations of the units aren't showing. The animations of the aliens, ships, and everything else so far is great! It's just the soldier guys that aren't showing up. I played a bit like this as well, but it just got annoying and hard to play since I couldn't tell who was in line of sight, and who was getting hit.

    On both programs I adjusted the game settings. The lower settings on VMWare made some icons disappear, though I could still click them. The settings on Parallels did nothing.
    I setup 256mb video on Parallels, which did nothing.
    I also set the ram on both to 1gig which also did nothing.

    Does anyone have any suggestions on how to fix this?
    Should I also post this on the gaming or apple programs boards?
     
  2. MacDawg macrumors P6

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #2
    No, duplicate threads will be deleted, so one posting is what you want

    Gaming is almost always going to be better running natively with Boot Camp
    Fusion and Parallels will not be able to match the performance

    If you are going to game, I would suggest you give that a try

    Woof, Woof - Dawg [​IMG]
     
  3. mikeyPotg thread starter macrumors 6502

    Joined:
    Mar 20, 2006
    #3
    Thanks, I've used boot camp before. It worked great, but I'm really just trying to find a way to multitask while in the preferable mac OS.
     
  4. micsaund macrumors 6502

    micsaund

    Joined:
    May 31, 2004
    Location:
    Colorado, USA
    #4
    3D inside a VM is always a bit tricky. I've got GalCiv2 working in Fusion mostly, but it does have some glitches similar to what you're seeing.

    I don't even bother with Parallels anymore.

    There's not much to fiddle-with settings-wise, so just make sure you're on the latest Fusion release 2.0.4. That's about all I can suggest :(
     
  5. mikeyPotg thread starter macrumors 6502

    Joined:
    Mar 20, 2006
    #5
    Ah well, I figured as much. Thanks! Lets hope they update again soon.
     
  6. Dmac77 macrumors 68020

    Dmac77

    Joined:
    Jan 2, 2008
    Location:
    Michigan
    #6
    You're not going to get good gaming performance in a virtual machine. VMWare and Parallels aren't designed for gaming. If you want to play games under Windows bootcamp is your best best.

    Don
     

Share This Page