Garageband initializing taking For...ev....er...

Discussion in 'Mac Apps and Mac App Store' started by millerrh, Aug 27, 2007.

  1. millerrh macrumors 6502

    Joined:
    Sep 14, 2005
    #1
    How long does it take all of you to open up Garageband 08? Once I click on the Garageband icon, I get the Initializing screen for about 3 minutes before the program starts. Seems super long to me and wonder if that's normal. I'm running a 2.33 Macbook Pro 2 GB RAM so I wouldn't think it's anything about my system.
     
  2. ghall macrumors 68040

    ghall

    Joined:
    Jun 27, 2006
    Location:
    Rhode Island
    #2
    That's strange. Mine never takes more than about 30 seconds. Does this happen consistently?
     
  3. millerrh thread starter macrumors 6502

    Joined:
    Sep 14, 2005
    #3
    Yes, this is very repeatable. I have extra loops loaded up that I have added (one jam pack and a bunch I made from a bunch of audio files). Maybe this is the cause? Still seems to take too long though.
     
  4. VIPER-X macrumors newbie

    Joined:
    Aug 20, 2007
    #4
    Possible Solution

    I've had the same scenario happen to my GarageBand today..

    Had beeen searching the net about it. Found out that in my case, it was the fonts problems. I have imported extra fonts into my OS X. Thats wad have been causing GarageBand not startup properly.

    Try moving your fonts folder. Got the below steps from Apple Support Discussion Online.


    1. Create a folder on your desktop called "OLD FONTS"
    2. go to the /Users/***/Library/Fonts folder, where "***" is the user that is having the problem loading GB.
    3. Move all of the fonts from this folder to the new folder you created in the first step. These are not system fonts, so it is okay to do this.
    4. Try to load GB. Thank God and do a happy dance!
    5. Put back fonts one letter of the alphabet at a time to find the offending font.

    Just trying to get a list of font families that doesnt work with GarageBand at the moment. Hopes apple fix this asap. :cool:
     
  5. millerrh thread starter macrumors 6502

    Joined:
    Sep 14, 2005
    #5
    I got all excited after reading this because I installed some new fonts about the same time I installed GarageBand 08. But after getting rid of all my fonts it still takes GarageBand about 3 mins to start up. Must be something besides (or in addition to) the fonts. Does anyone know what GarageBand is checking or loading during its initiallyzing phase? Could it be a library full of loops makes it take a long time to initialize?

     
  6. lavrishevo macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
  7. VIPER-X macrumors newbie

    Joined:
    Aug 20, 2007
    #7
    could be cache problem too.

    Couldn't start my GB after i used Onyx and clear the apps cache. Never gonna do that again.
     
  8. millerrh thread starter macrumors 6502

    Joined:
    Sep 14, 2005
    #8
    Optimized my system with Onyx and still takes forever. I can't wait for Leopard to come out. I think I'll be doing a complete reformat whenever I get Leopard to hopefully alleviate random things like this that seem to be cropping up lately.
     

Share This Page