Garageband Instrument Library Completely Missing

Discussion in 'Mac Basics and Help' started by BMasc814, Aug 5, 2009.

  1. BMasc814 macrumors newbie

    Joined:
    Aug 5, 2009
    #1
    A week ago I had to format my HD and reinstall Leopard last week. When I restored from my external HD afterward, I just clicked and dragged back the files and folders that I wanted instead of completely restoring the drive. I put Garageband back in my Apps folder. It didn't work when I opened it (something about an instrument library being invalid, what ever.). So I reinstalled iLife 09 from the disc, and now Garageband opens properly. The problem is that there are no (0) instruments in the library now, nor any loops.
    :mad::mad::mad::mad::mad::mad::mad::mad::mad:
    I know that normally there's an update available from Software Update that's about 1.1gb and includes all of the instruments and loops, but that update isn't appearing in the list.

    Anyone know what I can do? If someone can point me to a download/Rapidshare/torrent/ANYTHING of that update, or even a functional instrument library?
     
  2. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #2
    It's on your OSX install DVD that came with the machine. Try choosing Optional Installs

    The location on your hard drive for the instruments, loops etc. is in the Library: Applications Support: GarageBand folder
     
  3. BMasc814 thread starter macrumors newbie

    Joined:
    Aug 5, 2009
    #3
    Hm... is there any way I can do it without the install DVD? I'm not going to have access to it for like a month.
     
  4. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #4
    The instruments should be on the ILife 09 disk too.

    But no, there's no (legal) way to get the installer without the original disks.
     
  5. BMasc814 thread starter macrumors newbie

    Joined:
    Aug 5, 2009
    #5
    Alright, I see if I can find them on the disk.
    Thanks!
     
  6. BMasc814 thread starter macrumors newbie

    Joined:
    Aug 5, 2009
    #6
    Alright, so I went back to the iLife '09 disk installer, and clicked the "Customize" button on the "Installation Type" page.
    The Apple Loops/Instruments install package is there, but it's greyed out and it won't let me select the checkbox! I even went into the installer file with "Show Package Contents" and I can see the Loops installer file itself, but it's telling me to use "Customize" under the full iLife install, which, as I said earlier, doesn't work!
     
  7. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #7
    In that case, can you try a full reinstall of iLife?
     
  8. BMasc814 thread starter macrumors newbie

    Joined:
    Aug 5, 2009
    #8
    I deleted all of the Garageband files with AppCleaner, then retried the custom install and it worked.

    Thanks CanadaRAM and jessica.
    I guess we can close the thread now?
     
  9. mAcmAn413 macrumors newbie

    Joined:
    Jun 24, 2015
    #9
    Hey im missing the same file but i bought a used mac.. is it possible to share your insturment folder via email? if so reply at mo3ab0ss@gmail.com
     
  10. inscrewtable macrumors 65816

    inscrewtable

    Joined:
    Oct 9, 2010
    Location:
    Australia
    #10
    @mAcmAn413, why don't you have a bootable clone of your mac? Then you'd have all the files that you want in cases such as this.
     

Share This Page