Garageband Issue importing songs

Discussion in 'Mac Apps and Mac App Store' started by Link00seven, Jul 11, 2008.

  1. Link00seven macrumors regular

    Joined:
    Mar 6, 2008
    Location:
    Michigan, USA
    #1
    Hello,

    I'm having an issue importing songs from iTunes (AAC, MP3, etc) into Garageband. If I drag it from iTunes to Garageband, the plus sign appears and it says its importing the song, but then after one second it doesn't do anything. I've tried multiple files and this happens on all of them. I also tried putting the file on the desktop then dragging it in and that doesn't do anything at all (file just bounces back to the desktop.) I looked around in the menus and such and theres nothing in there that would refer to me being able to import tracks.

    Any advice on what the problem is? I just got the new iPhone 3G today and want to make me some ringtones.

    Thanks.
     
  2. cateariffic macrumors newbie

    Joined:
    May 23, 2008
    Location:
    Eugene, OR
    #2
    Arg!

    No one responded to you?! I'm having the same problem. I bought my computer in order to do this very thing and I can't do it. Infuriating!

    HELP!

    Cate
     
  3. miiles macrumors regular

    Joined:
    Aug 28, 2008
    Location:
    California
    #3
    Try click on the button that has a music symbol, and a iTunes viewer should open up. I have some attached pictures (the button is on the right in my second)

    The first picture is the window you should see when it opens up.

    Hope this helps.
     

    Attached Files:

  4. jodelli macrumors 65816

    jodelli

    Joined:
    Jan 6, 2008
    Location:
    Windsor, ON, Canada
    #4
    Go to the iTunes library in Finder without launching iTunes and drag the file from there into the Garageband tracks window. It works for me.

    Garageband converts AAC, Wav and mp3 files to AIFF to work with them, at least in my version.
     
  5. cateariffic macrumors newbie

    Joined:
    May 23, 2008
    Location:
    Eugene, OR
    #5
    It's so weird, but it just isn't happening.

    I've tried dragging the file from Finder, and from the Media Browser in GarageBand. I've tried taking it from the recorder which has the file on its SD card. It claims to be importing. It takes as much time as I would suspect it to import, but the track remains empty.

    I've tried dragging the file into the track, into the place where it says "Drag Apple Loops Here," into random other spaces just for kicks.

    I've tried it in a house, with a mouse (well a track-pad), on a boat with a goat.

    I've tried it before coffee, after coffee, before beer, after beer. Nothing works!

    I do have two other songs that came from my digital recorder and got in there, and as I recall that's how I did it, just good old drag and drop, but it's not working now.

    It seems like it must be a user failure, but it also seems so stupendously simple I don't know how I could screw it up.
     
  6. penash macrumors newbie

    Joined:
    Oct 16, 2008
    #6
    Was this Resolved?

    I have the same issue, I have recorded interviews on a Marantz Digi Recorder onto flash cards and cannot import. It says it is but does nothing! It imports songs no worries. These are .mp3's it should work???

    HELP!
     

Share This Page