Garageband: no sound

Discussion in 'Mac Apps and Mac App Store' started by betsbillabong, Jan 25, 2007.

  1. betsbillabong macrumors regular

    Nov 13, 2004
    Hi everyone,

    I'm having trouble getting sound out of Garageband - I've boiled it down to simply trying to play simple Apple loops or use musical typing to play software instruments.

    Sound is working properly in all other applications, including iTunes, Peak and Final Cut Pro. Audio input/output is set to Built-In in both GB preferences and Audio-Midi preferences. The MIDI is recording (ie, I can see a track appear when I play, and I see levels in the track) but for some reason the audio is not getting down to the mixer below (volume is up all the way on individual track and bottom right main, mute is off).

    I'm running OS 10.4.8 with Garageband 3.0.2.

    Any suggestions? I'm working on something time-sensitive. Thanks!
  2. iSee macrumors 68040


    Oct 25, 2004
    In the Audio MIDI setup app, check the format of the audio output. I've had problems with some apps when the rate is set too high. If it isn't already, set it down to 44100 Hz... Good luck
  3. betsbillabong thread starter macrumors regular

    Nov 13, 2004
    Thanks, but no dice ;-(

    Hi ISee,

    Thanks for the idea - unfortunately I'm still not getting any sound. It was already set to 44kHz-16 bit. I tried changing it to 24-bit to see if that made any difference but it didn't.

    Any other ideas?
  4. betsbillabong thread starter macrumors regular

    Nov 13, 2004
    No Sound in GB: Problem Solved

    Okay - hopefully helping someone else out here. It was pretty obvious.

    I called Apple support and amazingly got through to someone really knowledgeable right away. He asked me to log in as another user to see if the problem persisted. It did not.

    He then had me trash the two GB files in my Home --> Library --> Preferences

    Now it works. Hope that helps someone. The 44.1kHz tip was a good one, though. Thanks, ISee.

  5. diburrup macrumors newbie


    Feb 10, 2008
    No Sound in GB

    This has happened to me several times and I finally figured out how to fix it. The Track has gotten corrupted somehow, but the audio is still good. You can simply create a new track and move the audio to it and it should play fine. All your volume/automation edits are lost tho... those are Track features. Hope this helps others...
  6. rhett7660 macrumors G4


    Jan 9, 2008
    Sunny, Southern California
    Do you have speakers that are set to digital or analog? I would check under the preference setting and see what your audio line out is. If you have digital I would change it to digital and see if that helps. I noticed this when I changed my speakers.
  7. diburrup macrumors newbie


    Feb 10, 2008
    I think I need to clarify the "no sound" problem I was having, we may be talking about 2 different issues here. My problem was everything was playing fine, then one track would just quit playing. Audio was there and the meter was reading like it was there, it was not on MUTE, but no sound. This is what I was referring to fixing by creating a new track and moving the audio to it. The track itself can become corrupt when the audio region is just fine.
  8. gavnor macrumors newbie

    May 15, 2008
    Garage Band No Sound - Good Solution

    Thank you, Thank you, diburrup. After an hour scraping around forums I found your simple workaround! Thanks it works. But what a bleedin pain. An audio composer that gets corrupted and can't play audio, nil points mac. Get it sorted. Any solutions to fixing this bug please tell.

    NB I had already done all the obvious checks, monitor on, mute off, system audio routed correctly.

    GB 5.1 on Intel MacBook
  9. jennyheise macrumors newbie

    Nov 2, 2013

    I was having this same problem... everything was working correctly EXCEPT on Garage Band (but the meter showed sound playing). I went to preferences and audio and it had somehow switched to Airplay. I just switched it to one of the other options. It started up again with no problems. Nothing lost. Hope this helps! :)

Share This Page